Port 443 not in use, yet apache won't start [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Port 443 not in use, yet apache won't start [Solved]

Postby rahil » 11. July 2012 07:12

Hi guys

I read a lot of posts and tried a lot of things, yet couldn't get Apache started on the system (OS: WIndows Server 2008 R2)

Port number 80 is in use on the system by McAfee framework and I don't have the rights to disable it. So I edited the httpd.conf file and changed 80 to 443. Yet, the xampp control beta 3 panel still shows apache trying to run on port 80 (and subsequently failing). It runs as a service for a split second and then stops.

Furthermore, I tried to run apache as a service using apache_start.bat which gives me the following error:

"Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : make_sock: could not bind to address [::]:443
(OS 10048)Only one usage of each socket address (protocol/network address/port)
is normally permitted. : make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Press any key to continue . . ."
rahil
 
Posts: 2
Joined: 11. July 2012 07:02
Operating System: Windows Server 2008 R2

Re: Port 443 not in use, yet apache won't start

Postby rahil » 11. July 2012 07:50

Well. I changed the port settings in the httpd-ssl file from 443 to 0909 and it works perfectly.

Thanks guys.
rahil
 
Posts: 2
Joined: 11. July 2012 07:02
Operating System: Windows Server 2008 R2


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 59 guests