I can not find PHP in XAMPP [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

I can not find PHP in XAMPP [Solved]

Postby JanHolland » 07. July 2012 18:33

OS Name Microsoft Windows XP Professional
Version 5.1.2600 Service Pack 3 Build 2600
OS Manufacturer Microsoft Corporation
System Name HP
System Manufacturer Hewlett-Packard
System Model HP Compaq dx2400 Microtower PC
System Type X86-based PC
Processor x86 Family 6 Model 23 Stepping 10 GenuineIntel ~2599 Mhz
BIOS Version/Date American Megatrends Inc. 5.35, 12/16/2008
SMBIOS Version 2.5
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "5.1.2600.5512 (xpsp.080413-2111)"
User Name HP\Administrator
Time Zone W. Europe Daylight Time
Total Physical Memory 2,048.00 MB
Available Physical Memory 1.18 GB
Total Virtual Memory 2.00 GB
Available Virtual Memory 1.96 GB
Page File Space 3.84 GB
Page File D:\pagefile.sys


xampp177 installed itself in C:\xampp with htdocs,php,phpMyAdmin (and many other)
In htdocs I see: _myProgs,index_initial.php

I try:
1. http://localhost/_myProgs/index.html --> can't establish a connection to the server at localhost.

2a: http://localhost/htdocs/index_initial.php
2b: http://localhost/index_initial.php
2b. http://localhost/_myProgs/index.php --> unable to connect

3: file:///C:/xampp/htdocs/index_initial.php --> mething is wrong with the XAMPP installation :-(

4: http://localhost/htdocs/_myProgs/index.php --> google with info

A. file:///C:/xampp/htdocs/_myProgs/index.html --> Hello World

B. file:///C:/xampp/htdocs/_myProgs/index.php
with (... <p><?php echo “Hello World”; ?></p> </body> ...)
giving empty screen/line

C: file:///C:/xampp/phpMyAdmin/phpinfo.php -=-> empty screen/line
http://localhost/xampp/phpMyAdmin/phpinfo.php --> unable to connect
http://localhost/phpMyAdmin/phpinfo.php -- idem

Summa summarum:

I cant find any road to use PHP

Anyone with a suggestion?

TIA !
JanHolland
JanHolland
 
Posts: 3
Joined: 07. July 2012 16:07
Operating System: XP

Re: I can not find PHP in XAMPP

Postby JonB » 09. July 2012 15:22

A. Did you start XAMPP?

B. What happens when you go to http://localhost/xampp/ ???

Good Luck
8)



ycf
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: I can not find PHP in XAMPP

Postby JanHolland » 10. July 2012 22:06

Thx for rour answer:
Re: A. Did you start XAMPP?

I am not very sure what you means, but
I stopped/ran {Apache mySql} several times.

I do not understand the INFO:
"Perhaps this program running on 64 bit"....OK but my PC =32bit
which of two expressions {if yes, if not}
"please ignore the message above" .... which of the two {current dir,install dir}



B. What happens when you go to http://localhost/xampp/ ???
changes into [http://localhost/xampp/splash.php] which
gives a collection of labguages.

When I choose English I get:
[Welcome to XAMPP for Windows!
Congratulations:
You have successfully installed XAMPP on this system!

Now you can start using Apache and Co. You should first try »Status« on the left navigation to make sure everything works fine.

For OpenSSL support please use the test certificate with https://127.0.0.1 or https://localhost

Good luck, Kay Vogelgesang + Kai 'Oswald' Seidler ]

(Compliments1, I never tried that .... ;-(

in left column I see: [XAMPP 1.7.7 PHP: 5.3.8. ]
and: I do not see "the test certificate" mentioned.

Now I do:[http:/localhost/htdocs/index.php,
http://localhost/index.php
http://localhost/xampp/htdocs/_myProgs/index.php
http://localhost/xampp/htdocs/index.php
http://localhost/xampp//index.php] -->
which all give [Object not Found]

phpinfo give [
PHP Version 5.3.8

System Windows NT HP 5.1 build 2600 (Windows XP Professional Service Pack 3) i586
Build Date Aug 23 2011 11:47:20
Compiler MSVC9 (Visual C++ 2008)
Architecture x86
Configure Command cscript /nologo configure.js "--enable-snapshot-build" "--disable-isapi" "--enable-debug-pack" "--disable-isapi" "--without-mssql" "--without-pdo-mssql" "--without-pi3web" "--with-pdo-oci=D:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8=D:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8-11g=D:\php-sdk\oracle\instantclient11\sdk,shared" "--enable-object-out-dir=../obj/" "--enable-com-dotnet" "--with-mcrypt=static" "--disable-static-analyze"
Server API Apache 2.0 Handler
Virtual Directory Support enabled
....]

From another site (http://bravo.newnetenterprises.com/wordpress/faqs/faqs-xampp-windows/) I got the advice
to look in: [C:\WINDOWS\system32\drivers\etc] as Administrator, which
I did.
I tried to look into: [C:\WINDOWS\system32\drivers\etc\host] as ADMINISTRATOR but
windows wanted an extension (txt,com,whatever) then.

I do not see how I can append the pics of these screens here :-(

Anyhow, I got _some movement in the PHP problem ....

When I find out something
I report back here,

Thx
Jan
JanHolland
 
Posts: 3
Joined: 07. July 2012 16:07
Operating System: XP

Re: I can not find PHP in XAMPP

Postby JonB » 11. July 2012 03:00

OK. maybe this will help --

http://localhost/xampp/htdocs/_myProgs/index.php


"your" programs belong under the 'DocumentRoot' for Apache -- \xampp\htdocs. The DoumentRoot is a special folder; the place to begin your web folder tree - its defined in the Apsche main configuration file, \xampp\apache\conf\httpd.conf ,

For example:
c:\xampp\_myProgs\index.php would correspond to http://localhost/_myProgs/index.php.

Good Luck
8)



ycf
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: I can not find PHP in XAMPP

Postby JanHolland » 12. July 2012 08:58

Thx (to you and others) for the suppport.

Everything works fine now (although the PHP is reacting slightly different=sharper on vars called but not defined).

Contemplating what kept me so long out of XAMPP,
one issue could be that
I did not let the "XMPPP Controll Panel" =[XCP]start/stop/Busy process for Apache do its work.

So my advice to this is:
Let XCP do its work and
do sthing other (get coffee or finish/send your message:-) before
really starting to use your local PHP.

Again: Thx2Everybody
JanHolland
 
Posts: 3
Joined: 07. July 2012 16:07
Operating System: XP

Re: I can not find PHP in XAMPP

Postby JonB » 12. July 2012 19:39

OK, glad its all working now.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: milaz357 and 58 guests