Strange errors again. [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Strange errors again. [Solved]

Postby Geri » 06. July 2012 22:13

o hai.

the motherboard of my server has been died, so i had to put our portal to another machine temporally, and i see serious network and connection problems.

the portal:
a php-fusion based community portal with
-daily 30-300 visitor
-daily 200-2000 pageload
-daily ~100000 http request

this portal succesfully runned for months on the folowing machine:
-VIA 1,2 ghz CPU, downclocked to 533 mhz
-ECS green motherboard
-256 mbyte RAM
-Windows XP sp3
-10 gbyte HDD

the new computer where i must host this:
-AMD K7 2x1666 mhz
-MSI K7D motherboard
-1 gbyte RAM
-Windows XP sp3
-160 gbyte HDD
so its mutch powerfull than the previous server.

sympthoms:
-After 10-20 minutes of run, the data begins to be corrupt, for example, the portal body being sended corruptly, only the top of the site being opened in the browsers, and a half minutes later it maybe displays the whole page, or the load just stays in a deadlock
-after another 5 minutes, this error becomes more popular, and at the end, there is every page load being corrupt
-some php pages being stay normal, others being corrupted
-after another 5 minutes, the whole service fails. no requests being served

xampp version:
-i had some old, but i refreshed to the newest version (i downloaded it today). problem still exist.

other softwares:
-i uninstalled antivirus and firewall from my computer, and rebooted the machine. problem still exist.

other parameters about the error:
-the problem also exist if i browse it through localhost, so i think my router is O.K.
-no suspicious connections according to accesslog

if somebody have an idea, please tell it.

greetings: Geri
Geri
 
Posts: 20
Joined: 02. August 2011 14:10
Operating System: linux

Re: Strange errors again.

Postby JonB » 07. July 2012 15:11

Well, for starters - you should probably look in the error log(s)

Its quite possible that there are configuration changes needed. Not knowing either the application(s), the language versions used, or -- anything else, its nigh to impossible to guess what is wrong.

Good Luck
8)




ysf
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Strange errors again.

Postby Geri » 07. July 2012 18:58

i started xampp, and waited until the bug appeard again. it did. i see this in error log in apache:

[Sat Jul 07 19:47:56 2012] [notice] Digest: generating secret for digest authentication ...
[Sat Jul 07 19:47:56 2012] [notice] Digest: done
[Sat Jul 07 19:48:03 2012] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Jul 07 19:48:03 2012] [notice] Server built: Sep 10 2011 11:34:11
[Sat Jul 07 19:48:03 2012] [notice] Parent: Created child process 3060
[Sat Jul 07 19:48:07 2012] [notice] Digest: generating secret for digest authentication ...
[Sat Jul 07 19:48:08 2012] [notice] Digest: done
[Sat Jul 07 19:48:12 2012] [notice] Child 3060: Child process is running
[Sat Jul 07 19:48:12 2012] [notice] Child 3060: Acquired the start mutex.
[Sat Jul 07 19:48:12 2012] [notice] Child 3060: Starting 150 worker threads.
[Sat Jul 07 19:48:12 2012] [notice] Child 3060: Starting thread to listen on port 443.
[Sat Jul 07 19:48:12 2012] [notice] Child 3060: Starting thread to listen on port 80.
[Sat Jul 07 19:48:37 2012] [error] [client 85.190.0.3] File does not exist: F:/FTP/WEBSRV/xampp2012/htdocs/freenode-proxy-checker.txt
[Sat Jul 07 19:48:37 2012] [error] [client 85.190.0.3] File does not exist: F:/FTP/WEBSRV/xampp2012/htdocs/freenode-proxy-checker.txt
[Sat Jul 07 19:48:39 2012] [error] [client 83.137.41.33] script 'F:/FTP/WEBSRV/xampp2012/htdocs/proxytest.php' not found or unable to stat
[Sat Jul 07 19:48:41 2012] [error] [client 83.137.41.33] script 'F:/FTP/WEBSRV/xampp2012/htdocs/proxytest.php' not found or unable to stat


<- basically, nothing.


i also have downclocked my computer, its very hot in these days. no result.
Geri
 
Posts: 20
Joined: 02. August 2011 14:10
Operating System: linux

Re: Strange errors again.

Postby Geri » 07. July 2012 18:59

php error log contains no data for today at all.
Geri
 
Posts: 20
Joined: 02. August 2011 14:10
Operating System: linux

Re: Strange errors again.

Postby JonB » 11. July 2012 03:07

[Sat Jul 07 19:48:37 2012] [error] [client 85.190.0.3] File does not exist: F:/FTP/WEBSRV/xampp2012/htdocs/freenode-proxy-checker.txt
[Sat Jul 07 19:48:37 2012] [error] [client 85.190.0.3] File does not exist: F:/FTP/WEBSRV/xampp2012/htdocs/freenode-proxy-checker.txt
[Sat Jul 07 19:48:39 2012] [error] [client 83.137.41.33] script 'F:/FTP/WEBSRV/xampp2012/htdocs/proxytest.php' not found or unable to stat
[Sat Jul 07 19:48:41 2012] [error] [client 83.137.41.33] script 'F:/FTP/WEBSRV/xampp2012/htdocs/proxytest.php' not found or unable to stat


There's no way for us to 'guess' what your applications do or how they work, BUT - the above does not constitute "nothing" in my estimation. Should those clients be able to find those files, or is that a FIN scan? :shock:

Maybe you are experiencing a DDOS?

Good Luck

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Strange errors again.

Postby Geri » 12. July 2012 18:09

no, that is irc proxy scan.

however, i installed back my old server directly on the internet with a clean install - pentium2, 333 mhz, 128 mbyte RAM.
the problem seems to be solved. probably the router had some issues on the other machine.
so the problem is not related to xampp. topic can be closed.
Geri
 
Posts: 20
Joined: 02. August 2011 14:10
Operating System: linux

Re: Strange errors again. [Solved]

Postby JonB » 12. July 2012 19:38

OK, glad it worked out -

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 41 guests