FATAL ERROR: register_globals

Problems with the Windows version of XAMPP, questions, comments, and anything related.

FATAL ERROR: register_globals

Postby ahurd » 31. March 2004 01:01

I have installed XAMPP and am trying to bring up the index.php file in oscommerce, which I have unzipped in \htdocs, in my PhP editor, Maguma. I get the following:

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

After I do so by putting register_globals to on, I still get the same message. Could someone help? I am a total beginner! Thanks.

Albert Hurd
ahurd
 
Posts: 4
Joined: 31. March 2004 00:47

Postby Wiedmann » 31. March 2004 01:29

You must make the changes in the correct "php.ini" (because there are two there in different locations):
c:\xampp\apache\bin\php.ini
and restart apache
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ahurd » 31. March 2004 01:43

Thanks for your prompt reply. I changed both php.ini files, the one in \apache and the one in \php. Are there any others?

Albert
ahurd
 
Posts: 4
Joined: 31. March 2004 00:47

Postby Wiedmann » 31. March 2004 01:58

No. XAMPP have only two. One for PHP as cgi (/php) and one for mod_php (/apache/bin).

You can verify the setting with:
http://localhost/xampp/phpinfo.php

Search for "Configuration File". This one is used.
And "register_globals". Is it reallly "off"?

(A third place for this setting is in the file "httpd.conf". But I think, XAMPP don't use this place.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ahurd » 31. March 2004 03:03

phpinfo shows register_globals as off for both local and master values, even though it was set to on in both php.ini files (I found no reference to register_globals in httpd.conf). Very strange. What do you suggest I try next. Thanks for all your help.

Albert
ahurd
 
Posts: 4
Joined: 31. March 2004 00:47

Postby ahurd » 31. March 2004 03:27

Got it to work by rebooting. Apparently changes were not recorded even when I restarted apache. Thanks so much for all your trouble.

Albert
ahurd
 
Posts: 4
Joined: 31. March 2004 00:47

Postby Pc-dummy » 01. April 2004 13:26

HI abhurd

register_globals is a large security hole!

http://at.php.net/register_globals <-- look
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch


Return to XAMPP for Windows

Who is online

Users browsing this forum: Ceesdu and 48 guests