[XAMPP Control Panel v3.0.2] Apache Service Not Starting

Problems with the Windows version of XAMPP, questions, comments, and anything related.

[XAMPP Control Panel v3.0.2] Apache Service Not Starting

Postby RedCP » 01. July 2012 20:00

I'm trying to start Apache service on XAMPP Control Panel 3, however, it is not working.

I've tried to start it, yet it only says:

"Starting apache service...."

It started twice, but automatically stopped. Please help me.

Firefox can't establish a connection to the server at 127.0.0.1.
Last edited by RedCP on 01. July 2012 20:52, edited 1 time in total.
User avatar
RedCP
 
Posts: 12
Joined: 13. June 2012 05:10
Operating System: Windows 7 Home Premium

Re: [XAMPP Control Panel v3.0.2] Apache Service Not Starting

Postby Altrea » 01. July 2012 20:24

I have moved your thread to the english part of the board and delete your double post. Please before you post take a minute to check which is the correct forum for your post.

check your windows event log for information and error messages about windows services.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: [XAMPP Control Panel v3.0.2] Apache Service Not Starting

Postby RedCP » 01. July 2012 20:58

I'm not a genius, I'm not sure what you mean by this. Here's the log in XAMPP Control Panel 3 though:

3:56:51 PM [apache] Status change detected: running
3:56:52 PM [apache] Status change detected: stopped

In XAMPP Control:

Apache service started
Busy...
User avatar
RedCP
 
Posts: 12
Joined: 13. June 2012 05:10
Operating System: Windows 7 Home Premium

Re: [XAMPP Control Panel v3.0.2] Apache Service Not Starting

Postby Altrea » 01. July 2012 21:09

google for windows event log
that is what i meant.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: [XAMPP Control Panel v3.0.2] Apache Service Not Starting

Postby RedCP » 01. July 2012 21:17

The Apache service named reported the following error:
>>> The specified IP address is invalid.
User avatar
RedCP
 
Posts: 12
Joined: 13. June 2012 05:10
Operating System: Windows 7 Home Premium

Re: [XAMPP Control Panel v3.0.2] Apache Service Not Starting

Postby Altrea » 01. July 2012 21:19

There is your answer.
Your Apache configuration contains a wrong Ip address directive
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: [XAMPP Control Panel v3.0.2] Apache Service Not Starting

Postby RedCP » 01. July 2012 21:21

How can I change it to the correct one?
And what would the correct one be? Mine, or 127.0.0.1?
User avatar
RedCP
 
Posts: 12
Joined: 13. June 2012 05:10
Operating System: Windows 7 Home Premium

Re: [XAMPP Control Panel v3.0.2] Apache Service Not Starting

Postby Altrea » 01. July 2012 21:27

First you should find the place to edit.
Which setting is wrong?

It can be the Listen Setting, or the ServerName setting. Or any VHost setting.
We don't know what you have edit and which values you use.

Generally you don't tell very much helpful information to help you.
So at this time we can't solve your problem because we don't know exactly where and why the problem occurs.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: [XAMPP Control Panel v3.0.2] Apache Service Not Starting

Postby RedCP » 01. July 2012 21:56

I'm trying to do this, but I accidentally closed XAMPP. I'm trying to stop it with xampp-stop, but it says it can't find a few things....

Can't find apache\logs\httpd.pid.
Can't find mysql\data\mysql.pid.

:|
User avatar
RedCP
 
Posts: 12
Joined: 13. June 2012 05:10
Operating System: Windows 7 Home Premium

Re: [XAMPP Control Panel v3.0.2] Apache Service Not Starting

Postby Altrea » 01. July 2012 22:43

If you are running Apache as Service you should not use the xampp-stop.exe.
Either use the control panel to stop the service(s) or stop the services directly in your windows services window
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 73 guests