Another MySQL Admin not working problem [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Another MySQL Admin not working problem [Solved]

Postby dlm84741 » 27. June 2012 20:27


I'm using XAMPP version 1.7.7 on a Windows XP sp3 machine. A couple of weeks ago I was having problems just getting PHP to run (my localhost was trashed). Installing the latest version of xampp seems to have resolved that problem. But I'm currently having trouble with MySQL and Mercury. This post is only about the MySQL problem. I mention the others just in case it matters.

I start everything manually manually from the xampp control panel (after I stop IIS and it's attendant processes). Apache is running fine and it appears that MySQL is also running fine, on port 3306. But when i click the Admin button for MySQL on the xampp control panel i get the same two error messages I've seen in other posts.

"MySQL said: #2002 - The server is not responding (or the local MySQL server's socket is not correctly configured) "
"Connection for controluser as defined in your configuration failed."

I have only one instance of MySQL (mysqld.exe) running.

In my.ini I have this: socket= "C:/xampp/mysql/mysql.sock". There is no msql.sock in c:/xampp/mysql.

phpinfo() shows that mysql.default_socket local and master values are set to "MySQL", as does mysqli.default_socket.

Every thing looks fine when I run a netstat, mysql is listening on port 3306, and everything also looks fine in XP's windows task manager.

Here's the stuff from

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['extension'] = 'mysql';
$cfg['Servers'][$i]['AllowNoPassword'] = true;

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '';

Any help would be greatly appreciated


David Morris
Posts: 8
Joined: 08. March 2012 23:22
Operating System: XP sp3

Re: Another MySQL Admin not working problem

Postby JonB » 27. June 2012 21:09

try this:

Modified appropriate line in line to $cfg['Servers'][$i]['auth_type'] = 'cookie'; (was 'config') and the system works



Try this:
Thank you so much for replying! After 11 hours of head scratching I think I have just this second cracked it! I went into the my.ini file and changed the setting for mysql socket = "MySQL" to "/tmp/mysql.sock" and then did the same in the php ini file and it suddenly appeared!! I'm chuffed to bits!

Thank you again for taking the time to read my post.

Source: ... r-not.html

The MySQL socket is actually a non-entity on Windows as the Linux socket filetype is not supported, so it is engineered around. But MySQL also needs workspace.

#3 - personal favorite - you might need to bind to in your my.ini c:\xampp\mysql\bin\my.ini

Uncomment line 43 and restart.

Code: Select all

remove the hash (#) and save the file.

Source: Active memory.

Good Luck
User avatar
AF Moderator
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Another MySQL Admin not working problem

Postby dlm84741 » 28. June 2012 04:18

#1 did it!

Posts: 8
Joined: 08. March 2012 23:22
Operating System: XP sp3

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 94 guests