HOW TO CHANGE SERVER API??

Problems with the Windows version of XAMPP, questions, comments, and anything related.

HOW TO CHANGE SERVER API??

Postby pelle653 » 27. June 2012 13:05

How do i change server API from APACHE2HANDLER to CGI in XAMPP 1.7.7 for Windows XP??

I also need help to config some other things as well

- CGI Bin is not setup correctly! so how do i allow CGI to be accessed/excuted publicly and also whats the Perl directory?
pelle653
 
Posts: 2
Joined: 27. June 2012 13:02
Operating System: Windows

Re: HOW TO CHANGE SERVER API??

Postby JonB » 27. June 2012 16:53

- CGI Bin is not setup correctly!


What makes you say that??? or is that an error message you are getting?

Windows Explorer tells me the Perl directory/folder is \xampp\perl & the Perl executable is in the \xampp\perl\bin folder.


Good Luck
8)


ycf
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: HOW TO CHANGE SERVER API??

Postby pelle653 » 27. June 2012 16:58

yes its a message that pops up when running the setup of the script

here is the message : http://bayimg.com/OAPogAADF

so can i fix this?
pelle653
 
Posts: 2
Joined: 27. June 2012 13:02
Operating System: Windows

Re: HOW TO CHANGE SERVER API??

Postby JonB » 27. June 2012 20:24

A. What version of Windows are you running XAMPP on?

B. I am unaware of any reason that you should not be able to execute CGI programs in \xampp\cgi-bin. I run Perl scripts from that folder regularly on both XP and Windows 7. I think what they mean is 'you need to modify' the Handler to see Perl scripts as CGI files.

You will have to ask them if their script is mod_perl and Perl 5.10 compatible FIRST~. IF the script is compatible - this may fix everything.

Save/rename the original \xampp\apache\conf\extra\httpd-perl.conf file
copy C:\xampp177\apache\conf\extra\startup.pl to C:\xampp177\apache\conf\extra\startup.cgi

make this your new c:\xampp\apache\conf\extra\httpd-perl.conf:

Code: Select all
LoadFile "C:/xampp177/perl/bin/perl510.dll"
LoadModule perl_module modules/mod_perl.so
PerlPostConfigRequire "C:/xampp177/apache/conf/extra/startup.cgi"

<IfModule mime_module>
    AddType text/html .cgi
</IfModule>

<FilesMatch "\.cgi$">
    SetHandler perl-script
    PerlResponseHandler ModPerl::Registry
    PerlOptions +ParseHeaders
</FilesMatch>

<Directory "C:/xampp177/cgi-bin">
    <FilesMatch "\.cgi$">
        SetHandler cgi-script
    </FilesMatch>
</Directory>

# ASP settings
Include "conf/extra/httpd-perl-asp.conf"



C. On the assumption that you installed XAMPP in the root of C:\, the shebang line should look like this:
#!/xampp/perl/bin/perl.exe --

You should really check with them and tell them you installed on XAMPP, they may have a complete 'fix' already.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: DrSeussFreak and 65 guests