XAMPP+WP localhost issue...

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP+WP localhost issue...

Postby bdigges » 25. June 2012 20:13

Hi, I've followed some previous posts in here to help me setup XAMPP for hosting a testbed for WP dev. My goal is to have a WP site visitable by a remote user for the purposes of previewing and so forth. I've gotten that far. The problem I'm having is that none of the media/css for the site is being seen by the remote user. The sites are skeletal, just HTML formatted text and nothing else. But, the sites appear perfect to me when I view it in-browser from my own machine.

I understand this may not be within scope for XAMPP, but could anyone give me an idea why this would be happening?

-Thanks!
bdigges
 
Posts: 3
Joined: 25. June 2012 20:04
Operating System: Windows 7 64x

Re: XAMPP+WP localhost issue...

Postby Altrea » 26. June 2012 04:44

Hi bdigges,

Please check with tools like Firefox Firebug if the css and images and so on (everything which is requested with extra HTTP requests) can be accessed and if their URLs are correct. Very common that is your problem.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: XAMPP+WP localhost issue...

Postby bdigges » 27. June 2012 00:46

Hi Altrea!

Thanks for the response. I did as you said and double-checked the URL and file paths of the images and so forth. Everything seems fine from my end, so I don't see why a remote user would be having trouble seeing them?
bdigges
 
Posts: 3
Joined: 25. June 2012 20:04
Operating System: Windows 7 64x

Re: XAMPP+WP localhost issue...

Postby Altrea » 27. June 2012 03:53

You should check that from remote connection too, otherwise you can simply do as i can: guessing from far far away...
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: XAMPP+WP localhost issue...

Postby bdigges » 28. June 2012 18:58

Altrea wrote:You should check that from remote connection too, otherwise you can simply do as i can: guessing from far far away...


Hiya! I did what you said and it worked! Partially.

I search and replaced the working url to my local url. That helped, but for reason or another the site still won't load the theme for remote users. Any idea why this might be?

Thanks for all your help so far!
bdigges
 
Posts: 3
Joined: 25. June 2012 20:04
Operating System: Windows 7 64x

Re: XAMPP+WP localhost issue...

Postby JonB » 29. June 2012 15:18

You should probably check with the theme authors - OR better - simply remove the theme and re-install fresh on your local installation.

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 68 guests