XAMPP lite 1.7.7 cannot send email

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP lite 1.7.7 cannot send email

Postby feck » 22. June 2012 10:47

Ive seemed to follow some of the solutions here for this problem but still have no luck;

by PHP ini file is now;

[mail function]
; For Win32 only.
; http://php.net/smtp
SMTP = localhost
; http://php.net/smtp-port
smtp_port = 25

; For Win32 only.
; http://php.net/sendmail-from
sendmail_from = postmaster@localhost

; For Unix only. You may supply arguments as well (default: "sendmail -t -i").
; http://php.net/sendmail-path
sendmail_path = "\"\xampp\sendmail\sendmail.exe\" -t"


and my sendmail ini file is this;

; configuration for fake sendmail

; if this file doesn't exist, sendmail.exe will look for the settings in
; the registry, under HKLM\Software\Sendmail

[sendmail]

; you must change mail.mydomain.com to your smtp server,
; or to IIS's "pickup" directory. (generally C:\Inetpub\mailroot\Pickup)
; emails delivered via IIS's pickup directory cause sendmail to
; run quicker, but you won't get error messages back to the calling
; application.

smtp_server=smtp.gmail.com

; smtp port (normally 25)

smtp_port=25

; the default domain for this server will be read from the registry
; this will be appended to email addresses when one isn't provided
; if you want to override the value in the registry, uncomment and modify

;default_domain=local

; log smtp errors to error.log (defaults to same directory as sendmail.exe)
; uncomment to enable logging

error_logfile=error.log

; create debug log as debug.log (defaults to same directory as sendmail.exe)
; uncomment to enable debugging

debug_logfile=debug.log

; if your smtp server requires authentication, modify the following two lines

auth_username=********@gmail.com
auth_password=************

; if your smtp server uses pop3 before smtp authentication, modify the
; following three lines

;pop3_server=
;pop3_username=
;pop3_password=

; to force the sender to always be the following email address, uncomment and
; populate with a valid email address. this will only affect the "MAIL FROM"
; command, it won't modify the "From: " header of the message content

;force_sender=*****@smtp.gmail.com

; sendmail will use your hostname and your default_domain in the ehlo/helo
; smtp greeting. you can manually set the ehlo/helo name if required

;hostname=localhost


As you can see I'm using GMAIL for forwarding my mail, I have nothing else installed no Mercury, no other email client. Now what am i missing? My small php script is letting me know that the php script functioned correctly but I'm getting no emails in my destination email accounts inbox. Can anybody help?

{edit] I'm using Windows XP Service pack 2..... if that helps anyone
feck
 
Posts: 3
Joined: 21. June 2012 15:56
Operating System: Windows 7 64bit

Re: XAMPP lite 1.7.7 cannot send email

Postby JonB » 22. June 2012 14:20

You need to use or 'graft on' and configure the 'Sendmail' MTA that is bundled with XAMPP

Good Luck
8)



ysf
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: XAMPP lite 1.7.7 cannot send email

Postby feck » 22. June 2012 14:45

JonB wrote:You need to use or 'graft on' and configure the 'Sendmail' MTA that is bundled with XAMPP

Good Luck
8)



ysf


Are there any tutorials available online for that?
feck
 
Posts: 3
Joined: 21. June 2012 15:56
Operating System: Windows 7 64bit

Re: XAMPP lite 1.7.7 cannot send email

Postby JonB » 22. June 2012 17:17

Google to the rescue:

Google - 'CONFIGURE FAKE SENDMAIL'

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests