Apache - Unable to connect

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache - Unable to connect

Postby rjohnson1990 » 11. June 2012 18:43

I am having a problem with all versions of XAMPP. I tried 1.7.7 and thought that might have been the problem, but when I went back to 1.7.5, the version that worked fine before, it's doing the same thing. I keep getting the page that says "Unable to connect".

Image

I have port forwarded port 80 so that is not the problem.
I don't have Windows firewall turned on and Kaspersky firewall is not blocking port 80 so that is not the problem.
I can access everything perfectly when using localhost but when I use my IP, I get the page and I have to refresh several times before it works and it just stops randomly again.

I'm running Windows 7, 64 bit. Xampp 1.7.5 with CP 3.


Cable Modem Information
Cable Modem : DOCSIS 2.0 Compliant
MAC Address : 90:6E:BB:54:60:2A
Serial Number : A9B0716901440
Boot Code Version : 2.1.7d
Software Version : 6.23.1103
Hardware Version : 2.33
CA Key : Installed

Image
Image

The only solution I can come up with is my router situation but I don't think that's it. I have the UBEE modem/router through Time Warner. I also have a second router connected through that. I am connected to the UBEE modem/router though and the ports are forwarded in the UBEE gateway.
rjohnson1990
 
Posts: 15
Joined: 13. October 2010 23:11

Re: Apache - Unable to connect

Postby JonB » 11. June 2012 21:50

OK -

I am at a loss, where do you want to access from? Outside your network?

If so, are you using the WAN IP of the router? Is it a static or dynamic IP?

Just a question, does your ISP allow inbound Port 80 traffic? Some ISP's don't allow Port 80 inbound.

Some routers are configured to allow the ISP to use port 80 for management.

There are just a few possibilities.

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache - Unable to connect

Postby rjohnson1990 » 12. June 2012 04:26

This is what happens:

localhost and 192.168.0.100 work fine loading pages.
Using the IP that I got from www.whatismyip.com sometimes shows the pages, but when I click a different link on the website, it shows the unable to connect error. I can refresh several times and it will show up again.

I'm pretty sure Time Warner Cable doesn't block port 80. I had it working fine before with my D-Link 610 router, but now I'm having the problems after getting the UBEE router.
rjohnson1990
 
Posts: 15
Joined: 13. October 2010 23:11

Re: Apache - Unable to connect

Postby JonB » 12. June 2012 05:05

I'm afraid I have little to offer on a router/IP configuration issue. It 'appears' you have done the right things, but who am I to say?

Check with Time Warner to see if your IP is dynamic, pooled or static.

If it worked on the other router AND you have a static IP, I would call that self-explanatory. If you have a pooled or dynamic IP, then we have a different issue, but still one that is primarily a routing issue, not a server issue.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache - Unable to connect

Postby rjohnson1990 » 16. June 2012 21:21

Unsure about the router problem. Cannot connect to 192.168.1.1 without resetting the router to factory settings. I don't have the username or password. The guy from TWC set that router up as well and when I called, they said they don't have the information used. I don't want it set back to factory settings because I've had trouble with it before when I did that.

Anyone else have solutions of why my Xampp is giving me the error page?

You can check it out at www.computerdoctorx.tk.

I've tried connecting with my phone and other computers. It doesn't go through, and when it does, I get the error page after a while when I click to a different page.
rjohnson1990
 
Posts: 15
Joined: 13. October 2010 23:11

Re: Apache - Unable to connect

Postby Altrea » 17. June 2012 00:01

Hi rjohnson1990,

rjohnson1990 wrote:Anyone else have solutions of why my Xampp is giving me the error page?

If the router is the only component you switched it is very common that this component is the problem.
Sorry, we can't give any more support as JonB has already giving. Ask the manufacturer of your router what to do.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

"Unable to connect" Error

Postby rjohnson1990 » 18. June 2012 20:49

I have been having a problem for a few weeks now and I have been unable to find a solution to fix the problem.
I have a Ubee modem/router and a Linksys WRT150N router connected to that. My standard wireless connection is to the Linksys. Port 80 is forwarded on both routers.

When I go to localhost or 127.0.0.1, my website works.
When I go to my IP (24.58.***.***), sometimes it works, and sometimes it gives me the "Unable to connect" page error.

Here's my stats:

XAMPP: 1.7.5 with Control Panel 3
Windows 7 Home
64-bit


This is the hosts file from C:\Windows\System32\drivers\etc\:

# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

# localhost name resolution is handled within DNS itself.
# 127.0.0.1 localhost
# ::1 localhost
# 192.168.1.100 localhost
# 24.58.***.*** localhost


I was told putting in 192.168.1.100 and my outside IP might fix my problem but it didn't. I have not made any changes to XAMPP except the phpmyadmin settings.

If you have a solution, please post below. I am trying everything to get this working. I would like to upgrade to XAMPP 1.7.7 but it causes the same problems.
rjohnson1990
 
Posts: 15
Joined: 13. October 2010 23:11

Re: "Unable to connect" Error

Postby Altrea » 18. June 2012 23:21

I have merged your threads because it is still the same problem

rjohnson1990 wrote:This is the hosts file from C:\Windows\System32\drivers\etc\:

# 127.0.0.1 localhost
# ::1 localhost
# 192.168.1.100 localhost
# 24.58.***.*** localhost


I was told putting in 192.168.1.100 and my outside IP might fix my problem but it didn't.

  • a # at the beginning of a line comment this line out. It will not take any effect.
  • Defining multiple IPs for the same Name is nonsense. A DomainName can only be resolved to one IP (127.0.0.1 and ::1 is the only exeption)
    How should your Computer know which IP to choose? SHould it roll a dice?

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache - Unable to connect

Postby rjohnson1990 » 19. June 2012 16:18

Thank you. I'll give that a try and see what happens. I'm just wondering why it works fine one minute, and the next, I get the error on the web page. Hopefully this solves my issue.

* This actually isn't my problem either. It was working fine for a few minutes and then started to show the page again. All that is in my hosts file now is 127.0.0.1 and ::1
rjohnson1990
 
Posts: 15
Joined: 13. October 2010 23:11

Re: Apache - Unable to connect

Postby rjohnson1990 » 24. June 2012 22:33

I actually thought of this and wondered of this could be the problem...

I have Team Viewer installed and with it running, Apache doesn't start. With it not running, could that still be my problem?
rjohnson1990
 
Posts: 15
Joined: 13. October 2010 23:11

Re: Apache - Unable to connect

Postby Altrea » 24. June 2012 22:49

If Teamviewer is configured to use Ports 80 and 443 (which isby defalt) that is a very common reason.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache - Unable to connect

Postby rjohnson1990 » 25. June 2012 00:33

That's not it either. I uninstalled Team Viewer, removed all the entries in the registry. I'm not sure what else it could be.

This is my hosts file:
# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

# localhost name resolution is handled within DNS itself.
127.0.0.1 localhost
::1 localhost



Port 80 is forwarded on both routers.
Nothing is blocking port 80.
Shows on localhost and 127.0.0.1, once in a while on my outside IP found on www.whatismyip.com.
Randomly started this a while back.

Any idea why this is happening? Tried wamp as well and did the same thing.
rjohnson1990
 
Posts: 15
Joined: 13. October 2010 23:11


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests