apache does not run

Problems with the Windows version of XAMPP, questions, comments, and anything related.

apache does not run

Postby iprogramplus » 05. June 2012 01:48

hi,
installed XAMPP.
however, when going to http://localhost does not work.
in control panel only MySQL is running not Apache
iprogramplus
 
Posts: 6
Joined: 05. June 2012 01:41
Operating System: windows 7 64bit

Re: apache does not run

Postby JonB » 05. June 2012 02:19

what is in the Apache error log?

:?:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: apache does not run

Postby iprogramplus » 05. June 2012 02:52

I restarted XAMPP when in control panel, trying to start apache I get "ERROR Apache service not started [-1]'
iprogramplus
 
Posts: 6
Joined: 05. June 2012 01:41
Operating System: windows 7 64bit

Re: apache does not run

Postby JonB » 05. June 2012 04:03

OK -

The most likely things are:

A:
You have other programs/services running on Ports 80 or 443

Use the 'netstat' button in the Control Panel to see what is running on either ports 80 and/or 443. (you should use the xampp-control-3-beta OR download the newest version from the topic above in this board)

B: Your firewall may be blocking Apache - create an exception for httpd.exe in \xampp\apache\bin.

Good Luck
8)



ycf
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: apache does not run

Postby Altrea » 05. June 2012 04:51

Hi iprogramplus,

Do you have already installed the Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) Runtime?
Thats a requirement for the current XAMPP versions.

JonBs suggestions are true too. Please check them as well.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: apache does not run

Postby iprogramplus » 05. June 2012 11:56

hi
I am using version 2.5 where is the netstat button?
can you provide a link to ver 3 beta?
thanks
iprogramplus
 
Posts: 6
Joined: 05. June 2012 01:41
Operating System: windows 7 64bit

Re: apache does not run

Postby Altrea » 05. June 2012 13:45

Hi iprogramplus,

iprogramplus wrote:can you provide a link to ver 3 beta?

Either use the xampp-control-3-beta.exe in your \xampp\ folder (it is Control Panel v 3.0.2) or Download the very last version of that control panel here: viewtopic.php?f=16&t=48932

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: apache does not run

Postby iprogramplus » 05. June 2012 14:26

thanks,
I see port 80 and 443 in use by skype
iprogramplus
 
Posts: 6
Joined: 05. June 2012 01:41
Operating System: windows 7 64bit

Re: apache does not run

Postby iprogramplus » 05. June 2012 14:31

I turned skype off and it works, however, how do I run both Apache and Skype?
iprogramplus
 
Posts: 6
Joined: 05. June 2012 01:41
Operating System: windows 7 64bit

Re: apache does not run

Postby Altrea » 05. June 2012 14:32

We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests