Error 101 and Child Process exited with 255

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error 101 and Child Process exited with 255

Postby gaggid1 » 01. June 2012 16:58

I am facing this strange issue where i am getting below given notice every minute. Resulting i am getting Error 101 on few pages on my joomla website./ Please help me out with these errors. So that i can understand what's causing them....


Code: Select all
[Fri Jun 01 21:20:05 2012] [notice] Child 5660: Starting 150 worker threads.
[Fri Jun 01 21:20:05 2012] [notice] Child 5660: Starting thread to listen on port 443.
[Fri Jun 01 21:20:05 2012] [notice] Child 5660: Starting thread to listen on port 5001.
[Fri Jun 01 21:20:33 2012] [notice] Parent: child process exited with status 255 -- Restarting.
[Fri Jun 01 21:20:33 2012] [notice] Digest: generating secret for digest authentication ...
[Fri Jun 01 21:20:33 2012] [notice] Digest: done
[Fri Jun 01 21:20:36 2012] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Fri Jun 01 21:20:36 2012] [notice] Server built: Oct 18 2010 01:58:12
[Fri Jun 01 21:20:36 2012] [notice] Parent: Created child process 5080
[Fri Jun 01 21:20:36 2012] [notice] Digest: generating secret for digest authentication ...
[Fri Jun 01 21:20:36 2012] [notice] Digest: done
[Fri Jun 01 21:20:38 2012] [notice] Child 5080: Child process is running
[Fri Jun 01 21:20:38 2012] [notice] Child 5080: Acquired the start mutex.
[Fri Jun 01 21:20:38 2012] [notice] Child 5080: Starting 150 worker threads.
[Fri Jun 01 21:20:38 2012] [notice] Child 5080: Starting thread to listen on port 443.
[Fri Jun 01 21:20:38 2012] [notice] Child 5080: Starting thread to listen on port 5001.
[Fri Jun 01 21:20:41 2012] [notice] Parent: child process exited with status 255 -- Restarting.
[Fri Jun 01 21:20:41 2012] [notice] Digest: generating secret for digest authentication ...
[Fri Jun 01 21:20:41 2012] [notice] Digest: done
[Fri Jun 01 21:20:44 2012] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Fri Jun 01 21:20:44 2012] [notice] Server built: Oct 18 2010 01:58:12
[Fri Jun 01 21:20:44 2012] [notice] Parent: Created child process 3760
[Fri Jun 01 21:20:45 2012] [notice] Digest: generating secret for digest authentication ...
[Fri Jun 01 21:20:45 2012] [notice] Digest: done
[Fri Jun 01 21:20:47 2012] [notice] Child 3760: Child process is running
[Fri Jun 01 21:20:47 2012] [notice] Child 3760: Acquired the start mutex.
[Fri Jun 01 21:20:47 2012] [notice] Child 3760: Starting 150 worker threads.
[Fri Jun 01 21:20:47 2012] [notice] Child 3760: Starting thread to listen on port 443.
[Fri Jun 01 21:20:47 2012] [notice] Child 3760: Starting thread to listen on port 5001.
[Fri Jun 01 21:22:58 2012] [notice] Parent: child process exited with status 255 -- Restarting.
[Fri Jun 01 21:22:58 2012] [notice] Digest: generating secret for digest authentication ...
[Fri Jun 01 21:22:58 2012] [notice] Digest: done
[Fri Jun 01 21:23:00 2012] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Fri Jun 01 21:23:00 2012] [notice] Server built: Oct 18 2010 01:58:12
[Fri Jun 01 21:23:00 2012] [notice] Parent: Created child process 6876
[Fri Jun 01 21:23:01 2012] [notice] Digest: generating secret for digest authentication ...
[Fri Jun 01 21:23:01 2012] [notice] Digest: done
[Fri Jun 01 21:23:03 2012] [notice] Child 6876: Child process is running
[Fri Jun 01 21:23:03 2012] [notice] Child 6876: Acquired the start mutex.
[Fri Jun 01 21:23:03 2012] [notice] Child 6876: Starting 150 worker threads.
[Fri Jun 01 21:23:03 2012] [notice] Child 6876: Starting thread to listen on port 443.
[Fri Jun 01 21:23:03 2012] [notice] Child 6876: Starting thread to listen on port 5001.
[Fri Jun 01 21:23:06 2012] [notice] Parent: child process exited with status 255 -- Restarting.
[Fri Jun 01 21:23:06 2012] [notice] Digest: generating secret for digest authentication ...
[Fri Jun 01 21:23:06 2012] [notice] Digest: done
[Fri Jun 01 21:23:08 2012] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Fri Jun 01 21:23:08 2012] [notice] Server built: Oct 18 2010 01:58:12
[Fri Jun 01 21:23:08 2012] [notice] Parent: Created child process 5692
[Fri Jun 01 21:23:09 2012] [notice] Digest: generating secret for digest authentication ...
[Fri Jun 01 21:23:09 2012] [notice] Digest: done
[Fri Jun 01 21:23:11 2012] [notice] Child 5692: Child process is running
[Fri Jun 01 21:23:11 2012] [notice] Child 5692: Acquired the start mutex.
[Fri Jun 01 21:23:11 2012] [notice] Child 5692: Starting 150 worker threads.
[Fri Jun 01 21:23:11 2012] [notice] Child 5692: Starting thread to listen on port 443.
[Fri Jun 01 21:23:11 2012] [notice] Child 5692: Starting thread to listen on port 5001.
gaggid1
 
Posts: 12
Joined: 09. May 2012 16:13
Operating System: Windows 7

Re: Error 101 and Child Process exited with 255

Postby gaggid1 » 01. June 2012 17:02

I just check my event viewer as well. And see following error several times.

Code: Select all
Log Name:      Application
Source:        Application Error
Date:          6/1/2012 9:18:43 PM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      INGNSER-PCVWEB.heroites.com
Description:
Faulting application name: httpd.exe, version: 2.2.17.0, time stamp: 0x4cbbe9e8
Faulting module name: php5ts.dll, version: 5.3.5.0, time stamp: 0x4d26013e
Exception code: 0xc00000fd
Fault offset: 0x00172a76
Faulting process id: 0x1b88
Faulting application start time: 0x01cd400e021f3b31
Faulting application path: C:\xampp\apache\bin\httpd.exe
Faulting module path: C:\xampp\php\php5ts.dll
Report Id: 4377fbe9-ac01-11e1-897a-001517f49f01
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2012-06-01T15:48:43.000000000Z" />
    <EventRecordID>3539</EventRecordID>
    <Channel>Application</Channel>
    <Computer>INGNSER-PCVWEB.heroites.com</Computer>
    <Security />
  </System>
  <EventData>
    <Data>httpd.exe</Data>
    <Data>2.2.17.0</Data>
    <Data>4cbbe9e8</Data>
    <Data>php5ts.dll</Data>
    <Data>5.3.5.0</Data>
    <Data>4d26013e</Data>
    <Data>c00000fd</Data>
    <Data>00172a76</Data>
    <Data>1b88</Data>
    <Data>01cd400e021f3b31</Data>
    <Data>C:\xampp\apache\bin\httpd.exe</Data>
    <Data>C:\xampp\php\php5ts.dll</Data>
    <Data>4377fbe9-ac01-11e1-897a-001517f49f01</Data>
  </EventData>
</Event>
gaggid1
 
Posts: 12
Joined: 09. May 2012 16:13
Operating System: Windows 7

Re: Error 101 and Child Process exited with 255

Postby JonB » 01. June 2012 18:24

You Apache is probably restarting itself.

Try to determine if this only happens when you are using Joomla. Try using the XAMPP Welcome pages for instance.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Error 101 and Child Process exited with 255

Postby gaggid1 » 01. June 2012 19:46

Well it doesn't happen with all joomla pages. Even i put the website on offline mode it keep happening.. I am running it on Windows Server 2008 R2. Before this i was running it on desktop class machine with windows 7. Never faced any problem.

I am using a component named as Kide chat. Which is AJAX based chat. Whenever usage goes high i start getting memory_limit messages from php. I increased the memory_limit but it never stopped. Making whole website go down. So i removed that component and changed memory_limit to 128M.

But still nothing changed. In event viewer i am getting C:\xampp\php\php5ts.dll error again and again after every few minutes. Seems like it runs for few second than crash than restart again. .


Please help me with this.
gaggid1
 
Posts: 12
Joined: 09. May 2012 16:13
Operating System: Windows 7

Re: Error 101 and Child Process exited with 255

Postby JonB » 04. June 2012 19:30

Well, speaking for myself, I have little to offer. XAMPP was never intended for production environments. The 'xampp related' (or so you think) problem you happen to have is almost certainly a PHP bug. What you are getting is an OS related error from your server. That is why it appears in your Windows server Event Log - Windows choked on something. Probably some call in Joomla.

Google this: "Faulting module name: php5ts.dll, version: 5.3.5.0, Exception code: 0xc00000fd "

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 26 guests