[HELP]Re-installation of XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

[HELP]Re-installation of XAMPP

Postby jhusly » 01. June 2012 10:02

Hi! before doing this post i quite make sure i am able to read everypages that google would return relevant to my case and finally decided to be a member here for help.

Problem : I'm no longer able to correctly install/run the XAMPP application and its services.

My case : I just have this new computer for less than a month, XAMPP was among of the first applications i installed for the purpose of php study and it works perfectly. After some installations of several application i found out that after opening the control panel and starting the apache, it would just say "Port Busy". Having not able to get the exact reason of the problem after reading online, i uninstalled the program directly using its uninstaller (not certain if i was able to stop all the services since as far as i remember, filezilla was installed as services), reboot and then install the same version of application (the latest one - 1.7.7). Now, this is where im having serious trouble since after installing, i found out that the control panel i used to is not installed together making the shortcut added on my desktop look for it when clicked. Tried installing/uninstalling for several times and came up the same.

This is where i do a little bit of readings on the internet (not fond of manuals :lol: ), removed skype, disable IIS through services.msc, scan for possible applications using the port 80/8080/443 for localhost which i found nothing using the command "netstat -aon" and 3rd party port scanner. Also tried running the "setup_xampp.bat" in the directory after installing a new copy hoping it might fix directory issues and used the beta control -panel to start the services. Unfortunately, nothing works for me.

Current error registered in the beta-control panel
3:08:27 PM [apache] Possible problem detected: file "c:\xampp\apache\bin\httpd.exe" not found - run this program from your XAMPP root directory!
3:08:27 PM [mysql] Possible problem detected: file "c:\xampp\mysql\bin\mysqld.exe" not found - run this program from your XAMPP root directory!
3:08:27 PM [filezilla] Possible problem detected: file "c:\xampp\FileZillaFTP\FileZillaServer.exe" not found - run this program from your XAMPP root directory!
3:08:27 PM [mercury] Possible problem detected: file "c:\xampp\MercuryMail\mercury.exe" not found - run this program from your XAMPP root directory!
3:08:27 PM [main] Starting check-timer
3:08:29 PM [apache] Starting apache app...
3:08:37 PM [mysql] Starting mysql app...


Also, i cant find any errorlogs on any of the services. Currently running in win7 ultimate 64bit.

What im still missing here? Please help me fix this issue. TIA
jhusly
 
Posts: 1
Joined: 01. June 2012 08:31
Operating System: Win7 64bit

Re: [HELP]Re-installation of XAMPP

Postby JonB » 04. June 2012 19:15

1. I suspect you did not remove the services first, before installing a new version. :?:

Look in the Windows Service manager, see if Apache, MySql and FileZilla are listed. If so, remove them (disable, then remove service)

http://www.howtogeek.com/howto/windows- ... sta-or-xp/

2. Now re-install. If you user the installer before, use the 7z DL this time (less problems)

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 78 guests