Page 2 of 2

Re: Apache won't start on any XAMPP I try to use

PostPosted: 19. May 2012 10:33
by Mike135
Well, I hijacked the Apache's .conf file and put "Listen 78" instead of "Listen 80" and now it works. Some program really used port 80 but I have no idea what it is. You can lock this thread now or something, I got my Apache up and running :)

Re: Apache won't start on any XAMPP I try to use

PostPosted: 20. June 2012 10:02
by bryani
I have had exactly the same problem but I have found a work around.
1.Navigate to XAMPP/xampp/.
2. Create shortcuts of "xampp_start.exe", "xampp_stop.exe" and xammp-control-3-beta.exe. and put them on the desk top.
3. Click 'control-3' to act as monitor.
4. Click 'xampp_start'. A command window opens indicating XAMPP is starting. DO NOT CLOSE the window. Minimize it by all means. The backgrounds of apache and mysql will become green and you are GO.
5. When finished, click 'xampp_stop'. A command widow appears indicating XAMPP is shutting down. When complete, both command windows disappear.
6. Close 'control-3. The green backgrounds will have disappeared.

I hope this help someone.

Re: Apache won't start on any XAMPP I try to use [Solved]

PostPosted: 12. July 2012 00:21
by Monickenish
I went to \xampp\xampp-control-3-beta.exe and attempted to start the apache server. The control 3 beta was able to tell me that port 80 is being used by vmware. The virtual machine network takes up port 80 but the control 3 beta will be able to tell you what program is actually blocking that port. just FYI. hope this helps.

Re: Apache won't start on any XAMPP I try to use [Solved]

PostPosted: 24. July 2012 15:23
by Test-User
Have you checked httpd-vhosts.conf file? Apache won't start in xampp if there is any error.

Re: Apache won't start on any XAMPP I try to use [Solved]

PostPosted: 24. July 2012 16:15
by Altrea
Test-User wrote:Have you checked httpd-vhosts.conf file? Apache won't start in xampp if there is any error.

@Test-User: This topic is already solved.
And i really don't know what error information you expect to find in the httpd-vhosts.conf file :shock:

Re: Apache won't start on any XAMPP I try to use [Solved]

PostPosted: 27. August 2012 01:47
by farhansabir
XAMPP Windows 1.8.0: I thought i better leave a quick note here. I am using Windows 7 Home Premium 64bit.

I installed xampp and it wont start apache. first for skype, which i resolved. But ...

Apache will not start because all the httpd conf files; including extras - for some reason have "C:C:" in the path. I had to replace them all to start xampp/apache.
Sample errors (if you run httpd from command prompt):

C:\xampp\apache\bin>httpd
httpd: Syntax error on line 35 of C:/xampp/apache/conf/httpd.conf: ServerRoot must be a valid directory

C:\xampp\apache\bin>httpd
httpd: Syntax error on line 456 of C:/xampp/apache/conf/httpd.conf: Syntax error on line 17 of C:/xampp/apache/conf/extra/httpd-xampp.conf: Invalid LoadFile path C:C:/xampp/php/php5ts.dll

C:\xampp\apache\bin>httpd
AH00526: Syntax error on line 28 of C:/xampp/apache/conf/extra/httpd-multilang-errordoc.conf:
<Directory "C:C:/xampp/apache/error"> path is invalid.

After this i edited every file in C:\xampp\apache\conf\extra

Hope it helps someone like me :)

Farhan