Apache won't start on any XAMPP I try to use [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache won't start on any XAMPP I try to use [Solved]

Postby Mike135 » 18. May 2012 12:53

I have reinstalled XAMPP 6 times and have tried lite versions, newer versions and older versions. My OS is Windows 7 Home 64-bit. Apache just won't start. I have tried command prompt and .bat launchers, nothing works. It just keeps shutting Apache down. Usually it only shows start button and won't start at all no matter how much I wait or press it. Sometimes it goes on for a second and then shuts down again. MySQL starts properly and I don't see any problems with it. I really need XAMPP 1.7.3 to deal with my PHP works. Here is a screenshot of the issue. Image
Mike135
 
Posts: 9
Joined: 18. May 2012 12:18
Operating System: Windows 7 64-bit

Re: Apache won't start on any XAMPP I try to use

Postby hackattack142 » 18. May 2012 14:48

I would make sure you do not have any other web servers running (other Apache, IIS, etc instances) or other programs that would block ports 80 or 443.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache won't start on any XAMPP I try to use

Postby Mike135 » 18. May 2012 14:49

No, I don't have IIS :/ I uninstalled Skype also. Some people say that it blocked their ports.
Mike135
 
Posts: 9
Joined: 18. May 2012 12:18
Operating System: Windows 7 64-bit

Re: Apache won't start on any XAMPP I try to use

Postby hackattack142 » 18. May 2012 14:57

Sometimes it seems Win7 comes with a service running called World Wide Publishing that uses Port 80. Check your services (Start > Run > services.msc) and stop/disable this service if it is there.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache won't start on any XAMPP I try to use

Postby Mike135 » 18. May 2012 15:03

No, there was no services named "World Wide Publishing".
Mike135
 
Posts: 9
Joined: 18. May 2012 12:18
Operating System: Windows 7 64-bit

Re: Apache won't start on any XAMPP I try to use

Postby JonB » 18. May 2012 15:33

Hi

Try running 'start_apace.bat' (found in the root of \xampp) from a Command Prompt/window, and see what it outputs.

Also - what is in the Apache error log?
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache won't start on any XAMPP I try to use

Postby Mike135 » 18. May 2012 15:48

@JonB

I ran it, but nothing happened. Image

Also, when I try to launch error logs with XAMPP, it says: "This file doesn't exist. Create one?" I am worried about this.
Mike135
 
Posts: 9
Joined: 18. May 2012 12:18
Operating System: Windows 7 64-bit

Re: Apache won't start on any XAMPP I try to use

Postby JonB » 18. May 2012 16:26

Also, when I try to launch error logs with XAMPP, it says: "This file doesn't exist. Create one?" I am worried about this.


Not to worry - an empty file means Apache NEVER actually started. 80% of the time that means a port was blocked (port in use OR blocked by a firewall). As I recall 1.7.3 did not try to start https/SSL automatically (port 443) - but this command will show all ports and the executables that are using them.

Try using a Command Window - run this command

net stat -b

http://commandwindows.com/netstat.htm


Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache won't start on any XAMPP I try to use

Postby Mike135 » 18. May 2012 16:40

@JonB

I netstated -b and not a single process used ports 80 and 443.
Mike135
 
Posts: 9
Joined: 18. May 2012 12:18
Operating System: Windows 7 64-bit

Re: Apache won't start on any XAMPP I try to use

Postby JonB » 18. May 2012 16:52

OK - on to the next suspect(s).

A. Check your firewall to see if there is an exception for \xampp\apache\bin\httpd.exe

B. Open one of those Command Window (IMPORTANT - Run as Administrator in Context Menu)
cd/navigate to the \xampp\apache\bin\ folder
enter a single command -
httpd.exe

If the Apache console window closes immediately or unexpectedly after startup, open the Command Prompt from the Start Menu --> Programs. Change to the folder to which you installed Apache, type the command httpd.exe, and read the error message. Then change to the logs folder, and review the error.log file for configuration mistakes. If you accepted the defaults when you installed Apache, the commands would be:

c:
cd "\Program Files\Apache Software Foundation\Apache2.2\bin"
httpd.exe

Then wait for Apache to stop, or press Control-C. Then enter the following:

cd ..\logs
more < error.log

http://httpd.apache.org/docs/2.2/platfo ... ml#wincons

http://httpd.apache.org/docs/2.2/invoking.html

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache won't start on any XAMPP I try to use

Postby Mike135 » 18. May 2012 17:18

@JonB

When I tried to execute "httpd.exe", I got an error message.

I have not installed apache, I thought it comes with XAMPP install. I have no directory in program files named: "Apache Software Foundation\Apache2.2\bin", I wonder what is going on.
Mike135
 
Posts: 9
Joined: 18. May 2012 12:18
Operating System: Windows 7 64-bit

Re: Apache won't start on any XAMPP I try to use

Postby Mike135 » 18. May 2012 17:45

@Altrea

I really haven't installed it. XAMPP just has an "apache\bin" directory which contains httpd.exe.

Okay, well I'll install it then manually.
Mike135
 
Posts: 9
Joined: 18. May 2012 12:18
Operating System: Windows 7 64-bit

Re: Apache won't start on any XAMPP I try to use

Postby Mike135 » 18. May 2012 18:12

I installed Apache http server but the httpd.exe still doesn't work.
Mike135
 
Posts: 9
Joined: 18. May 2012 12:18
Operating System: Windows 7 64-bit

Re: Apache won't start on any XAMPP I try to use

Postby JonB » 18. May 2012 18:22

A. Mike - that was just to show you the method Apache recommends - it was a direct quote from their documentation

I have not installed apache, I thought it comes with XAMPP install. I have no directory in program files named: "Apache Software Foundation\Apache2.2\bin", I wonder what is going on.


B It might be useful to know what the error message was as that was the whole point of that exercise.

When I tried to execute "httpd.exe", I got an error message.


Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache won't start on any XAMPP I try to use

Postby Altrea » 18. May 2012 18:26

Mike135 wrote:@Altrea

I really haven't installed it. XAMPP just has an "apache\bin" directory which contains httpd.exe.

Yeah i know. I realized that right after posting and rereading the whole topic.
So i decided to delete my post again. My bad!
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8288
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests