Slow XAMPP Windows 7 (way too slow ...)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Slow XAMPP Windows 7 (way too slow ...)

Postby zenorb » 18. May 2012 08:42

Hi

I have XAMPP 1.7.7 running on Windows 7 64 bit as a local development environment for sake of avoiding internet lag.

Ironically it is extremely slow. So much so probably far worse than being on an external host.

Webpages are taking 13 seconds to serve. It should be a split second. It's not the hard drive being busy so don't worry about that. Every drive is super fast 6GB/sec SATA 3 with O/S on SSD and xampp on its own drive.

I tried adding a hosts file with 127.0.0.1 localhost as suggested here - http://cubicspot.blogspot.com.au/2010/07/fixing-slow-apache-on-localhost-under.html

I even tried turning off Windows Firewall as suggested here http://community.apachefriends.org/f/viewtopic.php?t=25677
which is ultimately untenable. Made no difference anyway.

I see this performance woes thread here http://community.apachefriends.org/f/viewtopic.php?f=16&t=50463
But it doesn't appear to be about using XAMPP on the machine it's installed.

Some articles on the internet say just use WAMPserver instead.

Would like to know why XAMPP is performing so poorly though and give it a chance before giving up on it.

If I run Control Panel v3.0.2 instead I see three red warning lines -
possible problem detected: Port 80 in use by "httpd.exe"!
possible problem detected: Port 442 in use by "httpd.exe"!
possible problem detected: Port 3306 in use by "myslqd.exe"!

But aren't these the actual XAMPP components that are supposed to be running? I'm confused.
Uninstalling the services are starting manually just changes the warnings to -
"x:\xampp\apache\bin\httpd.exe" seems to be running on port 80?
"x:\xampp\apache\bin\httpd.exe" seems to be running on port 443?
"x:\xampp\mysql\bin\mysqld.exe" seems to be running on port 3306?

Any suggestions or pointers on how to troubleshoot and where I should look?

Cheers
z
zenorb
 
Posts: 6
Joined: 22. August 2011 02:26
XAMPP Version: 5.6.3
Operating System: Windows 7 64

Re: Slow XAMPP Windows 7 (way too slow ...)

Postby Altrea » 18. May 2012 10:23

Hi zenorb,

zenorb wrote:I tried adding a hosts file with 127.0.0.1 localhost as suggested here - http://cubicspot.blogspot.com.au/2010/0 ... under.html

I even tried turning off Windows Firewall as suggested here viewtopic.php?t=25677
which is ultimately untenable. Made no difference anyway.

I see this performance woes thread here viewtopic.php?f=16&t=50463
But it doesn't appear to be about using XAMPP on the machine it's installed.

Please try this fixes here too: viewtopic.php?f=16&t=47453&p=192011&hilit=slow#p192011
Deactivating IPv6 completely may fix some speed issues too.

zenorb wrote:Some articles on the internet say just use WAMPserver instead.

There is always a lobby for this or that stack. But in most cases this will not make any difference, because both stacks rely on the same Apache sources from Apachelounge.com.

zenorb wrote:If I run Control Panel v3.0.2 instead I see three red warning lines -
possible problem detected: Port 80 in use by "httpd.exe"!
possible problem detected: Port 442 in use by "httpd.exe"!
possible problem detected: Port 3306 in use by "myslqd.exe"!

But aren't these the actual XAMPP components that are supposed to be running? I'm confused.

The XAMPP control panel has not the functionality to identify these processes completely, especially not if they are running as services.
It can also be another Apache and MySQL installation, but you should know that, if you installed another one.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 6472
Joined: 17. August 2009 13:05
XAMPP Version: 5.5.19
Operating System: W7Ux64

Re: Slow XAMPP Windows 7 (way too slow ...)

Postby zenorb » 18. May 2012 13:23

Hi.

Thanks so much for the reply.

Didn't quite understand the significance of the article offered which seemed to be about people transmitting over the internet. But I am a total newbie.

I did find a simple solution that worked but I have little idea as to why and I feel like I'm not giving XAMPP the chance it deserves.

I uninstalled XAMPP and installed WAMPserver and now my environment is lightning fast with instant responses - just liked I hoped it would be. Sorry I found XAMPP too difficult - or should I say way too slow.

Let me know if anyone identifies a simple or obvious solution to have XAMPP work on Windows 7 64. Just didn't for me. Odd

Ta
z
zenorb
 
Posts: 6
Joined: 22. August 2011 02:26
XAMPP Version: 5.6.3
Operating System: Windows 7 64

Re: Slow XAMPP Windows 7 (way too slow ...)

Postby jpritcha » 23. May 2012 21:18

On my WIN7 x64 machine I found the Microsoft Security Essentials was getting in the way. I added the xampp directory to the ignore list and everything is now working well and quickly. :)
jpritcha
 
Posts: 1
Joined: 23. May 2012 21:11
XAMPP Version: 5.6.3
Operating System: WIN7 x86, WIN7 X64, WINXP sp3

Re: Slow XAMPP Windows 7 (way too slow ...)

Postby Feyisayo » 06. November 2012 16:55

Thanks for this response jprictcha. It worked on my Windows computer (Win7 starter 32-bit)

Feyisayo
Feyisayo
 
Posts: 2
Joined: 06. November 2012 16:52
XAMPP Version: 5.5.19
Operating System: Linux


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 40 guests