Apache is connecting to Port 80,443???

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache is connecting to Port 80,443???

Postby jessica_lamb » 12. May 2012 21:53

Yesterday I was trying to figure out how to install the OpenSSL certificate to the trusted roots Authoritation store or something like that but I think I changed something and made it worse. Now Apache is trying to connect to Port 80,443 then it shuts down. And I still didn't figure out how to install the certificate :evil:

I'm about ready to call it quits with this program because I've had nothing but problems with it since Saturday. Can someone please help me???? I'm new to all of this and I am trying my very best to understand and learn how to start using it but I need someone who can help me understand how to fix whatever it was that I did wrong and install the security certificate. I can't even view the certificate on my computer.

Thanks
jessica_lamb
 
Posts: 24
Joined: 07. May 2012 22:35
Operating System: Windows 7

Re: Apache is connecting to Port 80,443???

Postby hackattack142 » 13. May 2012 05:17

Apache listens for connections on ports 80 (standard HTTP port) and 443 (standard secure HTTP port) by default. You will need to be more specific as to what the problems are, what you were trying do to, and any error messages you encountered.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache is connecting to Port 80,443???

Postby jessica_lamb » 13. May 2012 21:21

I'm just trying to connect to the localhost. I cannot connect to the localhost anymore after I made the changes in the PHP file. Knowing me I probably changed something that wasn't supposed to be changed. The following is the only thing my Xampp Control panel says:
2:06:43 PM [main] Initializing main
2:06:43 PM [main] Windows version: 6.1 (build 7601) - Service Pack 1
2:06:43 PM [main] Xampp version: 1.7.7
2:06:43 PM [main] Control center version: 3.0.2 [ Compiled: Jul 21th 2011 - build #1 ]
2:06:43 PM [main] Running not as admin! This will work for all application stuff, but whenever you do
2:06:43 PM [main] something with services there will be a security dialogue! So think about running
2:06:43 PM [main] this application with administrator rights!
2:06:43 PM [main] Working with basedir: "c:\xampp\"
2:06:43 PM [main] Initializing moduls
2:06:43 PM [mysql] Possible problem detected: Port 3306 in use by "mysqld.exe"!
2:06:43 PM [main] Starting check-timer
2:06:57 PM [apache] Starting apache service...
2:07:08 PM [apache] Status change detected: running
2:07:19 PM [apache] Status change detected: stopped
2:12:27 PM [apache] Starting apache service...
2:12:38 PM [apache] Status change detected: running
2:12:46 PM [apache] Status change detected: stopped

It also states that when Apache starts it's connecting to PID(s) 1628 and to PORT(s) 80,443 and I only get the error that the local host is not available when I go in my browser. It was working fine until I changed the PHP stuff in the PHP.IND folder that was stated in my other post.
jessica_lamb
 
Posts: 24
Joined: 07. May 2012 22:35
Operating System: Windows 7

Re: Apache is connecting to Port 80,443???

Postby hackattack142 » 13. May 2012 21:28

What did you change in the PHP.ini file?

Are there any errors being reported in the /xampp/apache/logs/error.log?

Also, if you want to use Apache as a service (as it appears from your log) you should run the control panel with Admin rights (right-click on the xampp-control-3-beta.exe and select run as administrator).
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Apache is connecting to Port 80,443???

Postby jessica_lamb » 13. May 2012 21:38

I was changing the ;extension (taking out the ; ) to try and activate the openssl but then I forgot which one's that I had changed and after that the localhost would no longer open. Also below is the errors that are reported in the /xampp/apache/logs/error.log


[Thu May 10 11:45:56 2012] [notice] Digest: generating secret for digest authentication ...
[Thu May 10 11:45:56 2012] [notice] Digest: done
[Thu May 10 11:46:00 2012] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Thu May 10 11:46:00 2012] [notice] Server built: Sep 10 2011 11:34:11
[Thu May 10 11:46:00 2012] [notice] Parent: Created child process 6060
[Thu May 10 11:46:04 2012] [notice] Digest: generating secret for digest authentication ...
[Thu May 10 11:46:04 2012] [notice] Digest: done
[Thu May 10 11:46:07 2012] [notice] Child 6060: Child process is running
[Thu May 10 11:46:07 2012] [notice] Child 6060: Acquired the start mutex.
[Thu May 10 11:46:07 2012] [notice] Child 6060: Starting 150 worker threads.
[Thu May 10 11:46:07 2012] [notice] Child 6060: Starting thread to listen on port 443.
[Thu May 10 11:46:07 2012] [notice] Child 6060: Starting thread to listen on port 443.
[Thu May 10 11:46:07 2012] [notice] Child 6060: Starting thread to listen on port 80.
[Thu May 10 11:46:07 2012] [notice] Child 6060: Starting thread to listen on port 80.
[Thu May 10 12:13:10 2012] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/phreedom
[Thu May 10 15:56:41 2012] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/phreedom
[Fri May 11 05:58:30 2012] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Fri May 11 05:58:30 2012] [notice] Child 6060: Exit event signaled. Child process is ending.
[Fri May 11 05:58:31 2012] [notice] Child 6060: Released the start mutex
[Fri May 11 05:58:32 2012] [notice] Child 6060: All worker threads have exited.
[Fri May 11 05:58:33 2012] [notice] Child 6060: Child process is exiting
[Fri May 11 05:58:34 2012] [notice] Parent: Child process exited successfully.
[Fri May 11 05:58:46 2012] [notice] Digest: generating secret for digest authentication ...
[Fri May 11 05:58:46 2012] [notice] Digest: done
[Fri May 11 05:58:50 2012] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Fri May 11 05:58:50 2012] [notice] Server built: Sep 10 2011 11:34:11
[Fri May 11 05:58:50 2012] [notice] Parent: Created child process 5736
[Fri May 11 05:58:53 2012] [notice] Digest: generating secret for digest authentication ...
[Fri May 11 05:58:53 2012] [notice] Digest: done
[Fri May 11 05:58:56 2012] [notice] Child 5736: Child process is running
[Fri May 11 05:58:56 2012] [notice] Child 5736: Acquired the start mutex.
[Fri May 11 05:58:56 2012] [notice] Child 5736: Starting 150 worker threads.
[Fri May 11 05:58:56 2012] [notice] Child 5736: Starting thread to listen on port 443.
[Fri May 11 05:58:56 2012] [notice] Child 5736: Starting thread to listen on port 80.
[Fri May 11 05:58:56 2012] [notice] Child 5736: Starting thread to listen on port 443.
[Fri May 11 05:58:56 2012] [notice] Child 5736: Starting thread to listen on port 80.
[Fri May 11 06:07:48 2012] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/phreedom
[Fri May 11 20:21:30 2012] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Fri May 11 20:21:30 2012] [notice] Child 5736: Exit event signaled. Child process is ending.
[Fri May 11 20:21:31 2012] [notice] Child 5736: Released the start mutex
[Fri May 11 20:21:32 2012] [notice] Child 5736: All worker threads have exited.
[Fri May 11 20:21:37 2012] [notice] Child 5736: Child process is exiting
[Fri May 11 20:21:41 2012] [notice] Parent: Child process exited successfully.
[Fri May 11 20:21:54 2012] [notice] Digest: generating secret for digest authentication ...
[Fri May 11 20:21:54 2012] [notice] Digest: done
[Fri May 11 20:22:59 2012] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Fri May 11 20:23:00 2012] [notice] Digest: generating secret for digest authentication ...
[Fri May 11 20:23:00 2012] [notice] Digest: done
[Fri May 11 20:23:16 2012] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Fri May 11 20:23:16 2012] [notice] Digest: generating secret for digest authentication ...
[Fri May 11 20:23:16 2012] [notice] Digest: done
[Sat May 12 14:48:29 2012] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat May 12 14:48:29 2012] [notice] Digest: generating secret for digest authentication ...
[Sat May 12 14:48:29 2012] [notice] Digest: done
[Sat May 12 14:51:10 2012] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat May 12 14:51:10 2012] [notice] Digest: generating secret for digest authentication ...
[Sat May 12 14:51:10 2012] [notice] Digest: done
[Sun May 13 14:07:14 2012] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun May 13 14:07:14 2012] [notice] Digest: generating secret for digest authentication ...
[Sun May 13 14:07:14 2012] [notice] Digest: done
[Sun May 13 14:12:41 2012] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun May 13 14:12:41 2012] [notice] Digest: generating secret for digest authentication ...
[Sun May 13 14:12:41 2012] [notice] Digest: done

And I always forget to start it with Admin rights but thanks for reminding me.
jessica_lamb
 
Posts: 24
Joined: 07. May 2012 22:35
Operating System: Windows 7

Re: Apache is connecting to Port 80,443???

Postby Altrea » 13. May 2012 22:02

Hi Jessica,

If you are running Apache as Service and have problems with it please take a look into your Windows event log too.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache is connecting to Port 80,443???

Postby jessica_lamb » 13. May 2012 22:09

Thanks I didn't know that there was a windows event log (like I said this is all brand new to me) however this is what I get in that error file and there are quite a few but they are all the same:

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2012-05-12T20:51:14.000000000Z" />
<EventRecordID>13431</EventRecordID>
<Channel>Application</Channel>
<Computer>JessicaLamb-PC</Computer>
<Security />
</System>
- <EventData>
<Data>httpd.exe</Data>
<Data>2.2.21.0</Data>
<Data>4e6b3136</Data>
<Data>php5ts.dll</Data>
<Data>5.3.8.0</Data>
<Data>4e537a04</Data>
<Data>c0000005</Data>
<Data>000f8a80</Data>
<Data>18d4</Data>
<Data>01cd3080f39a8a1e</Data>
<Data>c:\xampp\apache\bin\httpd.exe</Data>
<Data>C:\xampp\php\php5ts.dll</Data>
<Data>35d82ebb-9c74-11e1-81d9-001e101f4da1</Data>
</EventData>
</Event>
jessica_lamb
 
Posts: 24
Joined: 07. May 2012 22:35
Operating System: Windows 7

Re: Apache is connecting to Port 80,443???

Postby hackattack142 » 13. May 2012 23:08

Are you certain you did not enable any other extensions in the PHP file? If you enable an extension that is missing dependencies, it could cause PHP to crash which causes Apache to crash.

I installed XAMPP 1.7.7 fresh, I added the 'extension=php_openssl.dll' to PHP.ini and this is my extensions list
Code: Select all
extension=php_bz2.dll
;extension=php_curl.dll
;extension=php_dba.dll
extension=php_mbstring.dll
extension=php_exif.dll
;extension=php_fileinfo.dll
extension=php_gd2.dll
extension=php_gettext.dll
;extension=php_gmp.dll
extension=php_imap.dll
;extension=php_interbase.dll
;extension=php_ldap.dll
;extension=php_mssql.dll
;extension=php_mysql_mysqlnd.dll
extension=php_mysql.dll
;extension=php_mysqli_mysqlnd.dll
extension=php_mysqli.dll
;extension=php_oci8.dll
;extension=php_pdo_firebird.dll
;extension=php_pdo_mssql.dll
;extension=php_pdo_mysql_mysqlnd.dll
extension=php_pdo_mysql.dll
extension=php_pdo_odbc.dll
;extension=php_pdo_pgsql.dll
extension=php_pdo_sqlite.dll
;extension=php_pdo_sqlite_external.dll
;extension=php_pgsql.dll
;extension=php_pspell.dll
;extension=php_shmop.dll
;extension=php_snmp.dll
extension=php_soap.dll
extension=php_sockets.dll
extension=php_sqlite.dll
extension=php_sqlite3.dll
;extension=php_sybase_ct.dll
;extension=php_tidy.dll
extension=php_xmlrpc.dll
extension=php_openssl.dll
The openssl entry was not in there by default.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests