XAMPP PORT 80 BUSY

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP PORT 80 BUSY

Postby vish_op » 11. May 2012 05:54

Dear All,
I am using XAMPP in windows xp service pack 2.I want to use mysql gui tools with that.
Anyhow apache sever is not starting.always it gets the message busy port 80.

How to solve this.Please help to resolve.

Thanks in advance.

Thank you,
Vishaka
vish_op
 
Posts: 1
Joined: 11. May 2012 05:47
Operating System: windows

Re: XAMPP PORT 80 BUSY

Postby shumicpi » 11. May 2012 07:36

Most likely it is Skype which must have blocked the port 80. If you are running skype, then you can easily change its ports. Go to Tools -> Advanced -> Connections
and uncheck the Use Port 80 and 443 option and close skype. Now again try to start Apache. you should be able to do it.
shumicpi
 
Posts: 1
Joined: 11. May 2012 07:18
Location: Bangladesh
Operating System: Windows XP

Re: XAMPP PORT 80 BUSY

Postby bandave » 12. May 2012 15:44

Hi,
I do not have Skype on my computer, but I am having the same issue. I have checked port 80 and it is listening to PID 4, but there is not PID 4 in task manager.
I just re-installed it about 15 minutes ago because of this issue.

What other steps could I take to get my Apache server running?

Thanks in advance.
bandave
 
Posts: 1
Joined: 12. May 2012 15:41
Operating System: Windows 7 64-bit

Re: XAMPP PORT 80 BUSY

Postby hackattack142 » 12. May 2012 16:24

Typically the System process uses PID 4. The common blocking service usually ends up being the World Wide Publishing service. Go to your Windows Services (Start > Run > services.msc), see if there is a 'World Wide Publishing' service, right-click it to get the Properties, click 'Stop' if it is running, change it from 'Automatic' to 'Disabled', then click okay.

You can see all the processes in your Task Manager by checking the 'Show processes from all users' box at the bottom of the 'Processes' tab.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: XAMPP PORT 80 BUSY

Postby mdrasel » 11. May 2016 22:53

i was faced same problem few days ago but when i exit skype and start my xampp then its working well from skype i make the port free by setting connection setting now its not creating any problem.
mdrasel
 
Posts: 3
Joined: 11. May 2016 22:50
XAMPP version: 1.8.0
Operating System: windows 10

Re: XAMPP PORT 80 BUSY

Postby Altrea » 11. May 2016 22:57

Commonly Skype will not identify with HTTP.sys PID 4 but a random PID of it's own process.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 37 guests