MySQL database Deactivated & Can't access phpmyadmin[solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySQL database Deactivated & Can't access phpmyadmin[solved]

Postby radit91 » 06. May 2012 07:02

Hi Guys. I have just installed XAMPP. And i have couple problems.


(1st) MySQL databse is not activated.
Image
I tried to fix this issue by erasing the '#' in the C:\xampp\mysql\bin\my.ini at the #blind-address="127.0.0.1". But still it does not work. Any idea how to solve this problem?


(2nd) I can't access xampp from localhost, but i can access it from 127.0.0.1. Is this fine or it should be fix too?


(3rd) I can't access phpmyadmin?
Image
Do you think i can't access phpmyadmin because the problem is related to my first and second question or there is another problem that need to be fix?

Thanks.
Last edited by radit91 on 06. May 2012 11:41, edited 1 time in total.
radit91
 
Posts: 6
Joined: 02. May 2012 15:32
Operating System: Windows 7 Homw Premium

Re: MySQL database Deactivated & Can't access phpmyadmin[hel

Postby radit91 » 06. May 2012 09:10

I find a post about the same topic on how to fix this problem. It say that to get rid of possibly other MySQL services in the registry. Now, i have SQL Server Management Studio, do i have to uninstall this? I hope i don't because i need it.
radit91
 
Posts: 6
Joined: 02. May 2012 15:32
Operating System: Windows 7 Homw Premium

Re: MySQL database Deactivated & Can't access phpmyadmin[hel

Postby radit91 » 06. May 2012 11:41

Finally it works. I found another old thread in 2008. I fix it by adding 127.0.0.1 localhost on the top of 0.0.0.0 localhost in the c:/windows/system32/drivers/etc file hosts. Well thanks Guys. :mrgreen:
radit91
 
Posts: 6
Joined: 02. May 2012 15:32
Operating System: Windows 7 Homw Premium

Re: MySQL database Deactivated & Can't access phpmyadmin[hel

Postby projecte1 » 14. May 2012 10:48

radit91 wrote:Finally it works. I found another old thread in 2008. I fix it by adding 127.0.0.1 localhost on the top of 0.0.0.0 localhost in the c:/windows/system32/drivers/etc file hosts. Well thanks Guys. :mrgreen:



Thanks radit91 for your experience. I will try to make the same like you. I'm a newbie and thank you very much for you personal experience. I save time and suffering.

Have a nice day and Cheers! :D
projecte1
 
Posts: 1
Joined: 14. May 2012 10:43
Operating System: windows

Re: MySQL database Deactivated & Can't access phpmyadmin[sol

Postby radit91 » 14. May 2012 14:11

projecte1 wrote:Thanks radit91 for your experience. I will try to make the same like you. I'm a newbie and thank you very much for you personal experience. I save time and suffering.

Have a nice day and Cheers! :D



You are welcome :wink: . It took me few 3 days of searching to find out how to fix it :( . I'm glad it doesn't just help me, but others too :oops: .

And finally, good luck and have a nice day to you too :D .

Cheers! :lol:
radit91
 
Posts: 6
Joined: 02. May 2012 15:32
Operating System: Windows 7 Homw Premium

Re: MySQL database Deactivated & Can't access phpmyadmin[sol

Postby hackattack142 » 14. May 2012 22:11

on the top of 0.0.0.0 localhost in the c:/windows/system32/drivers/etc file hosts.
Why is that in your HOSTS file?
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: MySQL database Deactivated & Can't access phpmyadmin[sol

Postby radit91 » 15. May 2012 00:04

hackattack142 wrote:
on the top of 0.0.0.0 localhost in the c:/windows/system32/drivers/etc file hosts.
Why is that in your HOSTS file?

Not sure. But, it works for now. :P
radit91
 
Posts: 6
Joined: 02. May 2012 15:32
Operating System: Windows 7 Homw Premium

Re: MySQL database Deactivated & Can't access phpmyadmin[sol

Postby hackattack142 » 15. May 2012 03:58

It really should not be in there and I do not want others reading this thread to add it by mistake.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: MySQL database Deactivated & Can't access phpmyadmin[sol

Postby radit91 » 15. May 2012 04:10

hackattack142 wrote:It really should not be in there and I do not want others reading this thread to add it by mistake.

I don't think it was a mistake. Because it works for me and it helps others to. If you think this thread is misleading, then just report it so it would be taken off. And don't complain about it to me, because I'm still a noob to XAMPP(but this solution works for me, and i got it from this forum long time ago in 2008). If you have an official solution, please post it here.

Ps : i do realize changing anything in the windows directory is really serious business. But it works just fine, i haven't have any problem running it. And if I do, i will post an update. I apologize for my lack of knowledge on XAMPP, like i said before "I'm still a noob". And if you ask technical question about XAMPP i can't really answer it. And Windows for that matter. Sorry that i can't answer your question.

Thank you and good day. :(
radit91
 
Posts: 6
Joined: 02. May 2012 15:32
Operating System: Windows 7 Homw Premium

Re: MySQL database Deactivated & Can't access phpmyadmin[sol

Postby Altrea » 15. May 2012 13:56

Hi radit91,

radit91 wrote:Because it works for me and it helps others to.

Thats crap. Just because it works for you doesn't mean that others should get confused by your configuration. Defining more than one IP address (in your case 0.0.0.0 and 127.0.0.1) to the same domain name (localhost) can have really confusing side effects.

Name resolution is no m:n relationship, it's 1:m (one ip address can be bind to many domain names, not the other way round). What do you think should a computer do if you have defined more than one ip address to the same domain name? Roll a dice?

radit91 wrote:If you think this thread is misleading, then just report it

Not the whole thread is misleading, but parts of your HOSTS configuration.

0.0.0.0 does have a different meaning than 127.0.0.1
The 127. network is made for loopback, which is needed for some of the server component communication.
0.0.0.0 is simply a dummy ip address which a computer gets right before it can get any ip address from dhcp or the own network adapter. If you bind a domain name to 0.0.0.0 it simply means drop everything from that domain name (which can be very helpful to to prevent some ads or malware, but not for localhost). It is not made for loopback.

radit91 wrote:And don't complain about it to me, because I'm still a noob to XAMPP

Because you are a noob we are trying to give you more information about whats going on with your system. That has nothing to do with a complaint, we just want to correct your information so that others will not adapt your wrong configuration just because you don't know exactly what you are doing there.

radit91 wrote:If you have an official solution, please post it here.

The official solution is, to add a HOSTS domain name resolution from localhost to 127.0.0.1 and to bind the MySQL Server in its configuration to 127.0.0.1 too.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 39 guests