Error 500

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error 500

Postby iskeen » 05. May 2012 16:37

I have this error also on my development machine. Here is the message:

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

Error 500
localhost
05/05/12 11:25:00
Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1

Here is the error log message from C:/xampp/apache/logs :
[Sat May 05 11:25:00 2012] [alert] [client ::1] C:/xampp/htdocs/xampp/.htaccess: Invalid file path C:C:\\xampp\\security\\xampp.users

Is there a way to correct the file path without having to reinstall all over again?
I do not have any problem seeing my projects or using phpMyAdmin or the database or communicating with my production machine. The problem is that I cannot get to localhost to see the xampp Welcome Page, so I can't do any admin from there or whatever is supposed to be done.

Thank you in advance for your help,
Ilene Skeen
"Art is the indispensible medium for the communication of a moral ideal."
--Ayn Rand
User avatar
iskeen
 
Posts: 10
Joined: 10. December 2009 07:47
Location: NYC
Operating System: Windows Vista, Win 8 (2 pcs)

Re: Error 500

Postby iskeen » 05. May 2012 16:53

Hello. I found the file path error in the .htaccess file. When I corrected the path, I got the popup login and was not allowed in because I had no id or password that I had set in installation. So then I got the "Forbidden" message!

So I took out the directive "required valid user" and now I can get in to localhost and see the Welcome Screen. I presume I will be able to set up users and then require them as needed, so for now my problem is solved.

So my problem seems to be solved, but if you have anything further add which I should consider, I would sincerely appreciate your input.

Thanks for having this wonderful facility and Apachefriends which is an outstanding package.

Ilene Skeen
"Art is the indispensible medium for the communication of a moral ideal."
--Ayn Rand
User avatar
iskeen
 
Posts: 10
Joined: 10. December 2009 07:47
Location: NYC
Operating System: Windows Vista, Win 8 (2 pcs)

Re: Error 500

Postby iskeen » 05. May 2012 20:03

Just an update on this. The security link for the xampp page did not open. It had a file not found error which had this message in the log:

[Sat May 05 10:36:09 2012] [alert] [client 127.0.0.1] C:/xampp/htdocs/xampp/.htaccess: Invalid file path C:C:\\xampp\\security\\xampp.users
The link file was security/lang.php?en

The reason for this problem was that the installation placed the .htaccess file inside the security/htdocs/ instead of outside it. When I moved the .htaccess and related files, I was then able to get into the security part of the xampp administration. In addition, phpMyAdmin would not let me into the database (which I had access to earlier).

At this point I put in a user for admin user 'root' with a password, restarted the computer and was able to verify all working correctly.

Bottom line: there are some minor installation errors in the package. Here are my suggestions:

1. The documentation starts off a little confusing. It says first use the top level of your drive but later it says you can put your installation where you want it. In the readme_en.txt it is quite confusing. There is a note in front of step 1 and then step 1. What it should say is:

Step 1: Unpack the package into root of the directory you will use for the installation, like c:\, e:\ or w:\.

I found out the hard way that if I put in on a drive other than the one which was going to hold the installation, the paths were messed up. In my case this was c:/xampp.

As it is, the security module and the status module both were not runnable until I fixed the paths (was getting cc:\\xmapp\\ etc.). Also the security was not runnable because the .htaccess files were in the wrong place.

I think that this distribution is labeled beta, so if this helps someone correct these minor items, it will be a help for future installs and maybe result in less frustrated calls for help.

Overall, I have the highest regard to Apache Friends and I have used xampp/php/mysql with great success since 2009. I only had to do this reinstall because I was trying to integrate ssl from PayPal not realizing that their instructions conflicted with the way xampp is running.

Thank you & sincerely,

Ilene Skeen
"Art is the indispensible medium for the communication of a moral ideal."
--Ayn Rand
User avatar
iskeen
 
Posts: 10
Joined: 10. December 2009 07:47
Location: NYC
Operating System: Windows Vista, Win 8 (2 pcs)

Re: Error 500

Postby Altrea » 05. May 2012 21:28

Hi iskeen,

I've separated your posts from the original thread, because HTTP Status Error 500 Issues can be very different.
Next time please follow the unwritten rule "one thread per user and issue".
This will help everybody:
  • The original poster have a chance to get his/her issue solved too
  • We can provide more overview and better help for the single issue
  • Others can search and scan the issues more easily with the board search

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8287
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests