Localhost = blank page, cant connect

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Localhost = blank page, cant connect

Postby benjay » 24. April 2012 21:40

Hi,
I have been running xampp lite 1.7.3 on my win 7 machine without problems. Then I didn´t use it for a while. In this time I had a virus infection which affected registry files - repaired -, changed several local services (deactivated them), updated firefox and some more changes. Now xampp is running, no problem, but I cant connect to localhost / 127.0.0.1. I have no idea what change affected xampp.
Port 80 is free, no Skype, no firewall, no antivirus, checked the host file.
No Browser problem - checked with FF and Chrome with the same result. Installed easyphp but the same problem - cant connect to localhost, the page keeps just loading, no error message.
Anyone an idea where to look next? Have read all threads but no result so far...
Thanks
Ben
benjay
 
Posts: 1
Joined: 24. April 2012 21:19
XAMPP Version: 1.8.3-2
Operating System: win7 32 bit

Re: Localhost = blank page, cant connect

Postby JonB » 27. April 2012 18:03

Might be your firewall.

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Localhost = blank page, cant connect

Postby Ivo Katrafilov » 29. April 2012 10:31

Hi,

I have the same problem with 1.7.7 xampp installer. I changed the port 80 to 1234 and Apache appears to be Running. My firewall is OFF.


Best Regards
Ivo Katrafilov
 
Posts: 2
Joined: 29. April 2012 10:26
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Localhost = blank page, cant connect

Postby JonB » 29. April 2012 13:08

Can you ping localhost and 127.0.0.1? What are the results?
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Localhost = blank page, cant connect

Postby meadwench » 16. October 2012 20:47

I know this is an older post, but I'm having the same issue. I have Apache listening at 8000 and 4433 because I have Skype, and am getting a blank page for both localhost and 127.0.0.1. I can ping both of these. I've checked my virus protection and it is allowing the apache server out. Any other ideas?

Vicky Rowe
meadwench
 
Posts: 1
Joined: 16. October 2012 20:18
XAMPP Version: 5.6.3
Operating System: Windows 7

Re: Localhost = blank page, cant connect

Postby JonB » 17. October 2012 22:23

what's the output in the Control Panel when you start up?

also - what are the exact URLs you are using trying to connect?
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Localhost = blank page, cant connect

Postby Caleb » 02. April 2013 12:33

Hi,
this is simple. If you have changed the default port(80) to e.g 81, all you need to access your default localhost page is:
http://localhost:81/
That will be in addition to any other changes like commenting out ssl if you needed to.
That was simple right?
Caleb
 
Posts: 1
Joined: 02. April 2013 12:27
XAMPP Version: 1.7.3
Operating System: Windows7

Re: Localhost = blank page, cant connect

Postby Micheleg39 » 06. November 2014 11:32

Hello All

I was having the same problem

I simply changed a few details and it is working using the link below

http://w3guy.com/fix-xampp-error-apache-shutdown-unexpectedly

hope this helps
Micheleg39
 
Posts: 1
Joined: 06. November 2014 11:27
XAMPP Version: 1.7.4
Operating System: windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 42 guests