Page 1 of 1

Tomcat will not start - failed reg query?

PostPosted: 21. April 2012 05:12
by colarama
Apache is up and running, but tomcat will not start. I've tried the standard and the beta control panels without success, and went to the catalina_start.bat script. The output is:


[XAMPP]: Searching JDK HOME with reg query ...
ERROR: The system was unable to find the specified registry key or value.
. [XAMPP]: Cannot find current JDK installation!
. [XAMPP]: Cannot set JAVA_HOME. Aborting ...
Press any key to continue . . .

I have actually manually set JAVA_HOME, as per the tomcat readme, and I even tried to set JDK_HOME. I have jre 6, jre 7, and jdk 7 installed, and JAVA_HOME is currently pointing at the jdk 7 path. I'm a little unclear why the startup is trying to set JAVA_HOME instead of just using it...

Any ideas what's going on here?

Re: Tomcat will not start - failed reg query?

PostPosted: 21. April 2012 16:23
by colarama
I'm going to chalk this one up to yet another fail by Oracle and their Java EE "product". I was trying to use the JDK that was installed as part of the Java EE install, but that JDK install had failed to register with windows.

Eventually I realized there was nothing in Java EE I was actually going to use, and uninstalled it, replacing it with a standard JDK install, which is now working flawlessly with the beta control panel and the command line .bat script (but not the "standard" xampp control panel).