Problem accessing port 80, Apache won't start [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem accessing port 80, Apache won't start [Solved]

Postby bayor1 » 20. April 2012 15:02

Just installed XAMPP and needed to install and start services like MySQL, Apache. This services have being installed but Apache service has to start. When i try to start it from the services, it says could not start, check system event log. When i check the apache error log it tells me Unclean shutdown of previous apache run but when try to start it from command prompt with (httpd -k start) it returns an error reading

(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its acces
s permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

I need help ASAP. Thanks a lot
bayor1
 
Posts: 7
Joined: 17. April 2012 21:48
Operating System: Windows 7

Re: Problem accessing port 80, Apache won't start

Postby Altrea » 20. April 2012 15:26

Hi bayor1,

First rule: If you want to get help from volunteers, you have to be polite. Some sort of greeting and complimentary close don't cost much time. Some sort of request with Please and a question mark would be polite too.

bayor1 wrote:I need help ASAP

Second rule: The volunteers at this board are spending their free time here trying to solve problems others had. They don't get any money for it. They all have their own jobs, hobbies, friends, families. And not every volunteer does have the same level of knowledge then the others. So, if you want to get help, you have to be patient. In most cases your thread will be answered within 48 hours, but in some cases it can last a week and maybe you get no answer at all.

If you need help ASAP hire a freelancer. There are many freelancers on the market which will solve all your problems reasonably priced.

bayor1 wrote:(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Seems like some sort of security script is blocking your start attempt. It could be a limited Windows user account, the windows user account control, a firewall or any other sort of security software (including port observer, antivirus, etc).
Second thing you should check is, if your port 80 is blocked by another application.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Problem accessing port 80, Apache won't start

Postby bayor1 » 21. April 2012 09:54

Hi Altrea,
I am very very sorry for writing the way i did. I am new which is no excuse for been impolite but promise it wont happen again and thanks very much for your reply.
I will try it out. Thanks again.

Regards
Bayor1
bayor1
 
Posts: 7
Joined: 17. April 2012 21:48
Operating System: Windows 7

Re: Problem accessing port 80, Apache won't start

Postby bayor1 » 25. April 2012 23:15

Hi Altrea
Thanks your for your last response. I have just noticed that port 80 is blocked by another application. Is there any way i can configure
Apache to use another port instead of port 80? Help please!

Regards
Bayor1
bayor1
 
Posts: 7
Joined: 17. April 2012 21:48
Operating System: Windows 7

Re: Problem accessing port 80, Apache won't start

Postby Altrea » 25. April 2012 23:50

bayor1 wrote:Is there any way i can configure
Apache to use another port instead of port 80?

Possible, but not recommend. If you change the Apache port you have to add the port on every HTTP request too.

If the other application is not a HTTP Daemon, you should try to configure that application to not use port 80 or port 443.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Problem accessing port 80, Apache won't start

Postby visionwebsoft » 01. May 2012 18:50

Hello!

Hopefully you have had your port problem solved.

On mine, I stopped Skype from running, restarted XAMPP control panel and then Apache started on port 80 just fine.

Hope this helps.
visionwebsoft
 
Posts: 1
Joined: 01. May 2012 18:47
Operating System: Win7x64

Re: Problem accessing port 80, Apache won't start

Postby bayor1 » 06. May 2012 10:41

Hi visionwebsoft,
Thanks for your response but i haven't solved the port problem yet. I stopped Skype from running, restarted XAMPP control panel, and still having same problem. I am thinking of making Apache use another port instead of port 80 but am having problems on getting this done. Please any advice will be really helpful. Thanks.

Regards
Bayor1
bayor1
 
Posts: 7
Joined: 17. April 2012 21:48
Operating System: Windows 7

Re: Problem accessing port 80, Apache won't start

Postby bayor1 » 06. May 2012 10:55

Hi Altrea,
Thanks your for your response really appreciate it.

Altrea wrote:Possible, but not recommend. If you change the Apache port you have to add the port on every HTTP request too.


I think i would rather go for the non recommended option for now but i will still need help on how to go about configuring Apache to use another port instead of port 80. Please help.

Regards
Bayor1
bayor1
 
Posts: 7
Joined: 17. April 2012 21:48
Operating System: Windows 7

Re: Problem accessing port 80, Apache won't start

Postby Altrea » 06. May 2012 11:43

Hi bayor1,

bayor1 wrote:I think i would rather go for the non recommended option for now but i will still need help on how to go about configuring Apache to use another port instead of port 80. Please help.

Thats not that difficult:
  • open your \xampp\apache\conf\httpd.conf file
  • change Listen 80 to for example Listen 8888
  • change ServerName localhost:80 to ServerName localhost:8888
  • save the file
  • restart your Apache
  • try the URL http://localhost:8888/

best wishes,
Altrea

P.S.: Don't remind which port your XAMPP control panel shows for starting, it is hardcoded.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Problem accessing port 80, Apache won't start

Postby bayor1 » 09. May 2012 13:20

Hi Atrea
Thanks very much for your last response as it was really helpful. Apache is now working perfectly using port 82. For now i will stick with that until i find out how i can make Apache use port 80. All the same, thanks very much fro your help, i really appreciate it.

Regards
bayor1
bayor1
 
Posts: 7
Joined: 17. April 2012 21:48
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 29 guests