Solved-apache died without log

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Solved-apache died without log

Postby hanpedro » 14. April 2012 23:44

My box is windows 7 x64 and installed xampp 1.7.7.

i:\xampp\apache\bin>httpd -k install
[Sun Apr 15 07:12:30 2012] [error] Apache2.2: Service is already installed.

i:\xampp\apache\bin>httpd -k start

i:\xampp\apache\bin>httpd -k shutdown
The Apache2.2 service is not started.


Apache does not started and leave no messages on command prompt and "apache\logs" folder.

At this case how to find any clue to resolve this problem?

Any comment would be appreciated.

Thanks in advance.
Last edited by hanpedro on 15. April 2012 09:42, edited 1 time in total.
hanpedro
 
Posts: 133
Joined: 09. February 2005 06:03
Operating System: SCientific Linux 6.1 x86

Re: apache died without log

Postby Altrea » 15. April 2012 00:00

Hello hanpedro,

Services were logged in Windows event log. Please take a look into this first.
If there is no hint to solve the problem you should remove the service and try to start the component directly from your XAMPP control panel to make sure, your components are working correct.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8299
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: apache died without log

Postby hanpedro » 15. April 2012 09:22

Altrea/

Thanks, and at "windows error reporting" there is a message after re-starting apache.

+ System
- Provider
[ Name] Windows Error Reporting
- EventID 1001
[ Qualifiers] 0
Level 4
Task 0
Keywords 0x80000000000000
- TimeCreated
[ SystemTime] 2012-04-15T08:18:00.000000000Z
EventRecordID 8185
Channel Application
Computer WebDevMachine
Security

- EventData
2605927378
1
APPCRASH
http://oca.microsoft.com/resredir.aspx? ... 160129acbf
0
httpd.exe
2.2.21.0
4e6b3136
php5ts.dll
5.3.8.0
4e537a04
c0000005
000f8a80

C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_httpd.exe_47186eeb0e56de8aa5b88107bad2816a875bf_1ddd1f8c

0
814e132a-86d3-11e1-976f-e0cb4e927675
0



What am I wrong?
hanpedro
 
Posts: 133
Joined: 09. February 2005 06:03
Operating System: SCientific Linux 6.1 x86

Re: apache died without log

Postby hanpedro » 15. April 2012 09:41

Resolved after replacing php with PHP 5.4 (5.4.1RC2) - ts at http://windows.php.net/qa/.
hanpedro
 
Posts: 133
Joined: 09. February 2005 06:03
Operating System: SCientific Linux 6.1 x86


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 40 guests