he below command supported by:version1.7.4 curl_init($theUR

Problems with the Windows version of XAMPP, questions, comments, and anything related.

he below command supported by:version1.7.4 curl_init($theUR

Postby lse123 » 25. March 2012 16:21

he below command supported by:
###### ApacheFriends XAMPP (Basispaket) version 1.7.4 ######
+ Apache 2.2.17
+ MySQL 5.5.8 (Community Server)
+ PHP 5.3.5 (VC6 X86 32bit) + PEAR
+ XAMPP Control Version 2.5 from http://www.nat32.com
+ XAMPP Security
+ SQLite 2.8.15
+ OpenSSL 0.9.8o
+ phpMyAdmin 3.3.9
+ ADOdb 5.11
+ Mercury Mail Transport System v4.62
+ FileZilla FTP Server 0.9.37
+ Webalizer 2.01-10
+ Zend Optimizer 3.3.0
+ Perl 5.10.1
+ Mod_perl 2.0.4
+ Tomcat 7.0.3

Code: Select all
$c = curl_init($theURL);
curl_setopt ($c, CURLOPT_RETURNTRANSFER, 1);
$xml = curl_exec($c);
curl_close($c);

$doc = new DOMDocument();
$doc->loadXML($xml);
$root = $doc->documentElement;

$theNodes = $root->getElementsByTagName('Item');
Leonidas Euripide Savvides
lse123
 
Posts: 143
Joined: 15. November 2008 13:49
Location: Polis, Paphos
Operating System: vista 64 ultimate

Re: he below command supported by:version1.7.4 curl_init($t

Postby Sharley » 25. March 2012 22:40

Curl is supported when enabled in the php.ini file.

Open \xampp\php\php.ini file in a text editor like notepad and uncomment this line (remove the ; from the beginning of the line)
Code: Select all
;extension=php_curl.dll
so it looks like this
Code: Select all
extension=php_curl.dll
Then save the file and restart Apache.

Only enable the curl extention for now and only enable extensions as they are needed or you may find there will be problems if you enable all the extensions.

Check that it is enabled by going to http://localhost/xampp/phpinfo.php and look for the curl section.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: he below command supported by:version1.7.4 curl_init($t

Postby lse123 » 26. March 2012 14:48

it was enabled from before, seems not this the problem, thanks... I was trying a deprecated amazon.com api web service search mashup...same time with google search but only google results appear...
Leonidas Euripide Savvides
lse123
 
Posts: 143
Joined: 15. November 2008 13:49
Location: Polis, Paphos
Operating System: vista 64 ultimate


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests