Mcrypt extension

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Mcrypt extension

Postby xampplover » 25. March 2012 15:26

I'm stuck how to enable & use a script required Mcrypt extension. But Mcrypt is built in for PHP 5.3.x on windows.

Image

I want to use this script
Code: Select all
https://github.com/ezimuel/PHP-Secure-Session/blob/master/SecureSession.php


When I include this file, script will throw an error

Code: Select all
throw new Exception("I cannot generate a secure pseudo-random key. Please use PHP >= 5.3 or Mcrypt extension");


From PHP
Code: Select all
5.3.0    MCRYPT_DEV_RANDOM and MCRYPT_DEV_URANDOM became available on Windows platforms.


I search and found couple question about this problem..
Code: Select all
http://stackoverflow.com/questions/8140920/updating-php-to-5-3-not-working
http://stackoverflow.com/questions/8138213/fail-to-use-session-in-php


Question : May I know what is the problem to get this script work? It's really about Mcrypt extension?
xampplover
 
Posts: 1
Joined: 25. March 2012 15:14
Operating System: Windows 7

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests