Problems accessing localhost [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problems accessing localhost [SOLVED]

Postby The_Antipawn » 24. March 2012 18:05

Cannot access localhost or 127.0.0.1 through my browser

Followed the instructions on a similar topic posted earlier in the forum, that is I added '127.0.0.1 localhost' to the Hosts file, I also cleared my browsers cache.
Any ideas?
The_Antipawn
 
Posts: 2
Joined: 24. March 2012 17:56
Operating System: Windows 7 Premium 64 bit

Re: Problems accessing localhost

Postby Sharley » 24. March 2012 23:20

First check in the file \xampp\apache\logs\error.log file and see if the last entries have a [OS10038] error message.

Usually the fix for your no 127.0.0.1 and localhost access is the following which worked for me the other day when I was also baffled by a once working localhost - the log file entry was the clue.

Click on the Start (Orb) in the Task Bar and type:
Run
Click Enter

In the Run box type
netsh winsock RESET
Click OK

The console window will flash then disappear when complete.

I did not have to reboot and was able to then access localhost and 127.0.0.1.

Clear your browser cache (Temporary Internet Files).

Please let me know if the above worked for you.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Problems accessing localhost

Postby The_Antipawn » 28. March 2012 15:58

Yes, I followed the above (and re-edited the hosts file for good measure), and it worked. Thanks.
The_Antipawn
 
Posts: 2
Joined: 24. March 2012 17:56
Operating System: Windows 7 Premium 64 bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests