Problem with Apache as Proxy in LAN, behind a proxy

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem with Apache as Proxy in LAN, behind a proxy

Postby crissen » 23. March 2012 10:11

Hi there,

I use Apache for so many years without a serious problems, that i got struck when I saw that I cannot get around this issue.

What's the issue:
I'm in a LAN that's behind a squid proxy. Any access to the outside world goes through this proxy.
On one machine in the LAN I have an Apache that tries to proxy requests to a certain location to a server outside of the LAN. Why this you might ask. Because i need to avoid the cross origin resource sharing.
I checked the logs on the squid proxy and the request doesn't reach it.
The whole process works like a charm when Apache (XAMPP) is on machines with direct access to Internet. But not when I'm behind a proxy.
What I presume is that the proxy settings of the machine where Apache is are not used.
Do you know if there is any configuration where i tell Apache to use machines proxy settings? Or where I could tell Apache that it is behind a proxy and give it the proxy settings?

Edit:
forgot to add the message in error-log
(OS 10060)Ein Verbindungsversuch ist fehlgeschlagen, da die Gegenstelle nach einer bestimmten Zeitspanne nicht richtig reagiert hat, oder die hergestellte Verbindung war fehlerhaft, da der verbundene Host nicht reagiert hat. : proxy: HTTP: attempt to connect to x.x.x.x:80 failed
crissen
 
Posts: 2
Joined: 23. March 2012 08:54
Operating System: Windows XP

Re: Problem with Apache as Proxy in LAN, behind a proxy

Postby crissen » 23. March 2012 15:10

The same happens when i proxy to local address
(OS 10061)Es konnte keine Verbindung hergestellt werden, da der Zielcomputer die Verbindung verweigerte. : proxy: HTTP: attempt to connect to 127.0.0.1:8080 (127.0.0.1) failed
crissen
 
Posts: 2
Joined: 23. March 2012 08:54
Operating System: Windows XP


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 31 guests