SoapClient https bug xampp 1.7.7

Problems with the Windows version of XAMPP, questions, comments, and anything related.

SoapClient https bug xampp 1.7.7

Postby lancecaraccioli » 21. March 2012 20:20

On my linux workstation this code works

Code: Select all
<?php
$url = "https://www.example.com/service.php?wsdl";
$client = new SoapClient($url);
$result = $client->authenticate('username','password');
var_dump($result);


however the same code on my windows machine under xampp 1.7.7 returns the error

"Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://www.example.com/service.php?wsdl' failed to load external entity ... "

I have verified that this soap end point works properly using soapUI.

previous versions of xampp required php_openssl extension to be uncommented in php.ini

this does not seem to be the cause anymore as my installation does not even contain that extension commented out as previous xampp version have.

How do I properly configure xampp so that a simple soap connection over https will work properly?

Thanks,
Lance
lancecaraccioli
 
Posts: 1
Joined: 21. March 2012 20:09
Operating System: windows 7

Re: SoapClient https bug xampp 1.7.7

Postby renholder » 13. April 2012 11:48

Just add this line to php.ini
Code: Select all
extension=php_openssl.dll


It works for me.
renholder
 
Posts: 1
Joined: 13. April 2012 11:43
Operating System: Windows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests