Can't use anything other than port 80 [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't use anything other than port 80 [SOLVED]

Postby Remmke » 11. March 2012 13:37

Alright first my setup:

Win7 32bit (clean virtualpc setup - bridged)
xampp 1.7.7

Windows Firewall disabled..
No other services or programs uses port 8080..

In httpd.conf i changed to following:

listen 8080
localhost:8080

Restarted apache service

Then i type http://127.0.0.1:8080/ and it doesn't work.
When i change it back to port 80 and restart it works again.

In matter of fact no other ports work beside port 80...

What could i be missing? :?
Remmke
 
Posts: 3
Joined: 11. March 2012 13:26
Operating System: Win7

Re: Can't use anything other than port 80

Postby Sharley » 11. March 2012 22:27

Remmke wrote:(clean virtualpc setup - bridged)
I am not familiar with what this means or if it will affect your XAMPP installation.

Remmke wrote:In httpd.conf i changed to following:

listen 8080
localhost:8080

Restarted apache service
3 Questions:
1. Did you save the httpd.conf file after editing the port changes?

2. How did you restart the Apache service?

3. Are you using the latest Version 3 Control Panel linked below my signature?

Note on the V3 Control Panel.
Simply extract all the files from the CPv3 folder in to the xampp installation folder and overwrite when asked - do not extract the CPv3 folder complete, only extract it's content.
Then right click the exe file to run as administrator and to create a shortcut to the desktop for example, for easier access.

Make sure that you have exited all other control panel versions before starting this latest version.

This version 3 (XCPv3) control panel has many new features including a much more detailed log window and a button to easily access the log files to help with troubleshooting start and running issues.

Regards,
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't use anything other than port 80

Postby Remmke » 12. March 2012 14:31

Sharley wrote:
Remmke wrote:(clean virtualpc setup - bridged)
I am not familiar with what this means or if it will affect your XAMPP installation.


It is just a virtual machine in virtualbox. I shouldn't not effect XAMPP at all but thought it should post it anyway.

Sharley wrote:3 Questions:
1. Did you save the httpd.conf file after editing the port changes?


Yes.

Sharley wrote:2. How did you restart the Apache service?


I used version 3 control panel to stop the service, also doubled checked in Windows Services to make sure it did indeed stop.

After the restart I can see in the control panel Apache uses the new port but I can't access it; tried localhost:8080 and 127.0.0.1:8080

Sharley wrote:3. Are you using the latest Version 3 Control Panel linked below my signature?


Yes.

:| What could be stopping me from using port 8080? There are no other programs beside XAMPP running so port 8080 is not in use.
Remmke
 
Posts: 3
Joined: 11. March 2012 13:26
Operating System: Win7

Re: Can't use anything other than port 80

Postby Sharley » 12. March 2012 23:05

Did you stop the service by removing the tick in the Service Module column and did you also Stop Apache by clicking on the Stop button first?

Make sure that your 2.5 older version Control Panel has exited and is not simply sitting in the Windows Tray area - it has to be exited by using the Exit button not by using the X button top right of the panel's window.

Click on the Quit button of the XCPv3 panel after stopping and removing the service ticks for all XAMPP components.

Next check in the Windows Task Manager under Processes that there are no httpd.exe, apache.exe or even control panel exe file processes running and if so then Kill them all.

Restart your XCPv3 panel by right clicking and selecting run as admin.

Do not click any Services tick boxes as your Windows services are not required at this testing stage - they should all show a red X not a green tick.

If port 80 works after starting Apache and MySQL using the defaults then once again Stop Apache and MySQL using the Start/Stop buttons in the XCPv3 and check once again there are no httpd.exe or apache.exe processes running.

Then edit your httpd.conf file to listen 8080, save it and then Start Apache using the Start /Stop button in the control panel (no Ticks) and see if it now starts on port 8080.

Finally if still having port 8080 issues make sure that any firewall or security software, for example, ZoneAlarm etc. that you may have installed, will allow port 8080 through.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't use anything other than port 80

Postby Remmke » 14. March 2012 20:00

Ok, forget everything i wrote here. Xampp wasn't the problem. It was Wordpress, I had no idea changing the port required a change in the Wordpress options. :oops:

Thanks for your time answering my questions..
Remmke
 
Posts: 3
Joined: 11. March 2012 13:26
Operating System: Win7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 51 guests