differences between xamp 1.7.7 and 1.6.6a

Problems with the Windows version of XAMPP, questions, comments, and anything related.

differences between xamp 1.7.7 and 1.6.6a

Postby alexgoaga » 11. March 2012 07:15

Good morning everyone, i have a question about the differences between xamp 1.7.7 and 1.6.6a because i don't understand why some of my scripts works perfectly on xamp 1.6.6a and when i put them into the new version of 1.7.7 some problems appear .

I need to upgrade my xamp from 1.6.6a because i have some scripts that does not work on 1.6.6a

I think there is a problem between php.ini from the new version but i don't know how to configure to be exactly like in 1.6.6a

I will put some images for an example of upgrading the versions :

Heres from 1.6.6a :

Image

It does work perfectly

and the same script in the new version 1.7.7

Image

Please can someone tell me how to solve this problem?
sorry to bother and for my english.
alexgoaga
 
Posts: 4
Joined: 11. March 2012 06:53
Operating System: Windows Xp

Re: differences between xamp 1.7.7 and 1.6.6a

Postby WilliL » 11. March 2012 16:45

hi alexgoaga,

the notices are shown, for you use an undefined variable. Its better to define variables before using.
You can block this notice by changing "error_reporting in c:\ xampp\php\php.ini

Code: Select all
error_reporting = E_ALL | E_STRICT
change to
error_reporting = E_ALL & ~E_NOTICE | E_STRICT  (Show all errors, except for notices)
or
error_reporting = E_ALL & ~E_NOTICE  (Show all errors, except for notices and coding standards warnings.)


may be there are changes in php on function extract()
http://php.net/manual/en/function.extract.php
Willi
WilliL
 
Posts: 661
Joined: 08. January 2010 10:54
Operating System: Win7Home Prem 64 SP1

Re: differences between xamp 1.7.7 and 1.6.6a

Postby alexgoaga » 12. March 2012 11:57

i have made the error reporting off but still i can't access any of my pages, stills stays on index page
alexgoaga
 
Posts: 4
Joined: 11. March 2012 06:53
Operating System: Windows Xp

Re: differences between xamp 1.7.7 and 1.6.6a

Postby Altrea » 12. March 2012 18:43

Warning: extract() expects parameter 1 to be array, null given in C:\xampp\htdocs\index.php

You should debug, why this value is null and not a valid array.

one possible explanation is register_globals
but nobody can know. It's your script.

So activate error_reporting and set it to the highest level to find all things that are not working correct.
The differences between the PHP versions can be huge.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 76 guests