Win Srv 2003 R2/Apache: XAMPP 1.7.7 not starting, 1.7.3 yes

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Win Srv 2003 R2/Apache: XAMPP 1.7.7 not starting, 1.7.3 yes

Postby natasha » 09. March 2012 11:33

I tried and install XAMPP 1.7.7 on a Windows Server 2003 R2 SP2 machine: I was unable and start Apache 2.2.
httpd.exe was unrecognized as a valid executable.
I used NirSoft Currport to be sure no service was using 80 port, I changed it in 8088 in httpd.conf... nope.
Disinstalled and reinstalled many times.
Finally, I downloaded XAMPP 1.7.3 from SourceForge and installed: it's all ok now.
I note that XAMPP 1.7.3 uses:
Code: Select all
xampp_cli.exe installservice apache

to install Apache as a service, whilst XAMPP 1.7.7 uses:
Code: Select all
httpd -k install


Available to all tests to solve this problem and improve XAMPP 1.7.7 installer.
natasha
 
Posts: 5
Joined: 08. September 2005 11:01
Operating System: Win XP Pro / 7 Ult / 2003 R2

Re: Win Srv 2003 R2/Apache: XAMPP 1.7.7 not starting, 1.7.3

Postby Sharley » 09. March 2012 11:47

Would you be so kind as to add your XAMPP version and Operating System to your profile as per these instructions and associated information:
viewtopic.php?f=16&t=48626
Thanks. :)

XAMPP for Windows 1.7.7 is compiled using VC9 (Visual C++ SP1) and so the runtime file (Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)) is needed and can be downloaded then installed using this Microsoft link which also contains full information:
http://www.microsoft.com/download/en/de ... px?id=5582

1.7.3 was compiled using VC6.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Win Srv 2003 R2/Apache: XAMPP 1.7.7 not starting, 1.7.3

Postby natasha » 13. March 2012 11:17

Done.
Sorry for the mistake.
natasha
 
Posts: 5
Joined: 08. September 2005 11:01
Operating System: Win XP Pro / 7 Ult / 2003 R2

Re: Win Srv 2003 R2/Apache: XAMPP 1.7.7 not starting, 1.7.3

Postby Sharley » 13. March 2012 11:37

natasha wrote:Done.
Sorry for the mistake.
Not a problem and thanks for updating your profile. :)

Did you manage to get Apache to start :?:
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests