XAMPP only run first time, not after restart

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP only run first time, not after restart

Postby sonnich » 07. March 2012 11:49

Hi

I have had win7 for some time and got a PHP project now.

I installed XAMPP (1.7.7 and before that some older version) and it
worked. The next day it did not work, so I downloaded the latest
version for 64bit reasons and it worked.
Now the same again, it does not start (apache and mysql), for apache
it says "busy".

What can cause this?

Sonnich
sonnich
 
Posts: 3
Joined: 07. March 2012 11:18
Operating System: Windows 7 and Windows XP

Re: XAMPP only run first time, not after restart

Postby Sharley » 07. March 2012 11:57

Please add your Windows version to your profile:
viewtopic.php?f=16&t=48626

Then read the \xampp\apache\logs\error.log file for clues.

Where did you install XAMPP to on your hard drive?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP only run first time, not after restart

Postby sonnich » 07. March 2012 11:59

The current problem is on Windows 7, but I also use Windows XP in other cases. Can I add both?
sonnich
 
Posts: 3
Joined: 07. March 2012 11:18
Operating System: Windows 7 and Windows XP

Re: XAMPP only run first time, not after restart

Postby Sharley » 07. March 2012 12:05

Use the version 3 control panel found in the xampp installation folder but exit the older 2.5 version first:
xampp-control-3-beta.exe
It has better error reporting log window.

Just to add, the latest and greatest Control Panel Version 3 download post is linked below my signature.
Simply extract all the files from the CPv3 folder in to the xampp installation folder and overwrite when asked - do not extract the CPv3 folder complete, only extract it's content.
Then right click the exe file to run as administrator and to create a shortcut to the desktop for example, for easier access.

Make sure that you have exited all other control panel versions before starting this latest version.

This version 3 (XCPv3) control panel has many new features including a much more detailed log window and a button to easily access the log files to help with troubleshooting start and running issues.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP only run first time, not after restart

Postby sonnich » 07. March 2012 13:06

Thanks. It tells me about the problem:

Possible problem detected!
2:05:03 PM [apache] Port 80 in use by "c:\program files (x86)\skype\phone\skype.exe"!
2:05:03 PM [apache] Possible problem detected!
2:05:03 PM [apache] Port 443 in use by "c:\program files (x86)\skype\phone\skype.exe"!

Any way to have both working at the same time?

Sonnich
sonnich
 
Posts: 3
Joined: 07. March 2012 11:18
Operating System: Windows 7 and Windows XP

Re: XAMPP only run first time, not after restart

Postby Sharley » 07. March 2012 13:13

Any way to have both working at the same time?
Yes there is.

No need to disable Skype just change the ports that it uses.

Skype uses ports 80 and 443 by default.

You can alter that behavior by going to:
Tools\Connection options...\Connections

Untick
Use port 80 and 443 as alternative for incoming connections

BTW XAMPP should be installed in C:\xampp not in C:\Program Files (X86)\xampp or you will have many more issues down the track.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP only run first time, not after restart

Postby iprogramplus » 05. June 2012 16:29

cheers :-)
iprogramplus
 
Posts: 6
Joined: 05. June 2012 01:41
Operating System: windows 7 64bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests