I have little perl experience, & am hoping to get bugzilla running under my Xampp apache server
I have apache 2.2.21 running, with MySQL 5.5 running.
I have followed the instructions at: https://wiki.mozilla.org/Bugzilla:Win32Install
but when I got to installing the correct perl modules it all went wrong.
The bugzilla site tells you to install activcestate perl. Xampp 1.7.7 comes with its own perl installation though. I still did the active perl installation (v 188.8.131.522), & then apache refused to start up again, with the error saying it cant find the file mod.perl.
I believe that this version of activestate perl is incompatible with the apache version (2.2.21) packaged with xampp 1.7.7?
Can anyone confirm or deny this?
Do I need ActiveState perl installed instead of the perl that comes with XAMPP?
I have since put the original perl installation that came with Xampp 1.7.7 & apache is starting hapily again. I believe the perl version that came with xampp is 5.10?
If I do need to install activestate perl for bugzilla, do I need to get activeState perl v 5.10 instead of the latest 5.14?
Anyway, I soldiered on with perl that came with xampp, and had a lot of problems:
- The bugzilla install guide ( https://wiki.mozilla.org/Bugzilla:Win32Install) talks about if you have perl v5.10, you need extra packages, and to use ppm to add repos & download packages. Going to the commandline, when I type in ppm, I get: "Failed to load PPM_DAT file, Can't use an undefined value as a SCALAR..."
After more digging on the internet I found that if I added the environment variable:
PPM_DAT = <my perlInstall>\perl\site\lib\ppm.xml
then ppm starts to work.
but it also has no idea of what a repo command is....
- so I kept going, & configured apache, & started on the bugzilla bit: checksetup.pl
this told me I needed to run the command line: perl install-module.pl DateTime
invoking this ends up with:
CPAN.pm: Going to build D/DR/DROLSKY/DateTime-0.72.tar.gz
Begin Failed--compilation aborted at Build.pl line 5
Module::Build version 0.3601 required--this is only version 0.35
- tried unsucessfully to install a newer version of build.
anyone know what I'm doing wrong?