Cannot connect localhost [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Cannot connect localhost [SOLVED]

Postby hooiyijun » 25. February 2012 04:23

Hi,

I have installed xampp in windows seven. And the apache with mysql is started. This means the port 80 with 3306 is being used by apache with mysql. But Why do i cannot load 127.0.0.1 or localhost via browser? When i stop apache, the browser will stop to load the link 127.0.0.1 or localhost. However, i have closed firewall, the problem still same. May i know what is the possible problem? I will grateful you if anyone mind spend time to provide the suggestion. I am really like to use the software xampp. This is benefit to many programmers which are able to write php script in local computer.

Regards,
Jun
hooiyijun
 
Posts: 6
Joined: 25. February 2012 04:05
Operating System: -

Re: Cannot connect localhost

Postby JonB » 25. February 2012 08:08

XAMPP 1.7.7 also requires that port 443 be free, as HTTPS is also enabled.

Check to see if that is your problem
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Cannot connect localhost

Postby hooiyijun » 25. February 2012 09:25

Thanks for the information. But i never use https. The version is not the 1.7.7.

Wish you the whole good Day.
hooiyijun
 
Posts: 6
Joined: 25. February 2012 04:05
Operating System: -

Re: Cannot connect localhost

Postby JonB » 25. February 2012 19:51

The version is not the 1.7.7.


then "why does it say XAMPP version 1.7.7 in your profile"?


Posts: 2
Joined: 24. February 2012 23:05
XAMPP Version: 1.7.7
Operating System: -




What version ARE you talking about?

:?:



ysf
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Cannot connect localhost

Postby hooiyijun » 26. February 2012 05:21

The version is 1.7.4. I don't know why i cannot load 127.0.0.1 via browser. It look like windows seven cannot support 1.7.4?
hooiyijun
 
Posts: 6
Joined: 25. February 2012 04:05
Operating System: -

Re: Cannot connect localhost

Postby JonB » 26. February 2012 18:27

1 - Make sure that IPv4 is enabled

2 - Using a CMD (Command) Window, try pinging 127.0.0.1 and localhost

3 - See if the Apache error log shows any issues.

Good luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Cannot connect localhost

Postby hooiyijun » 27. February 2012 06:00

Hi,

I ensure ipv4 is enabled. And the 127.0.0.1 pinging is successfully.

On another, i have checked error log.
The error log show the following a lot of message:
An operation was attempted on something that is not a socket. : Child 1548: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.

What's the mean of the above problem? Kindly advise. Thanks for very much.
hooiyijun
 
Posts: 6
Joined: 25. February 2012 04:05
Operating System: -

Re: Cannot connect localhost

Postby JonB » 27. February 2012 16:54

Its an Apache vs. Windows Error -- and the error log is telling you to how to possibly fix it.

An operation was attempted on something that is not a socket. : Child 1548: Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.



http://httpd.apache.org/docs/2.2/en/mod ... leacceptex

Stop XAMPP if it is running -

Edit \xampp\apache\conf\extra\httpd-mpm.conf

Look toward teh end for:

Code: Select all
<IfModule mpm_winnt_module>
    ThreadsPerChild      150
    MaxRequestsPerChild    0
    #Win32DisableAcceptEx
</IfModule>


Remove the # from:
#Win32DisableAcceptEx

should now look like:
Code: Select all
<IfModule mpm_winnt_module>
    ThreadsPerChild      150
    MaxRequestsPerChild    0
    Win32DisableAcceptEx
</IfModule>



Save the file. This will enable Win32DisableAcceptEx

Restart XAMPP and see what happens.

If it does not fix your problem - try disabling firewall software etc as suggested in the Apache documentation
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Cannot connect localhost

Postby hooiyijun » 28. February 2012 03:29

HI,

I enabled Win32DisableAcceptEx. But the problem still same. On another, error log also show the following message, so i cannot estimate what is the problem:

[Tue Feb 28 10:23:59 2012] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Tue Feb 28 10:23:59 2012] [notice] Digest: generating secret for digest authentication ...
[Tue Feb 28 10:23:59 2012] [notice] Digest: done
[Tue Feb 28 10:24:00 2012] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Tue Feb 28 10:24:00 2012] [notice] Server built: Oct 18 2010 01:58:12
[Tue Feb 28 10:24:00 2012] [notice] Parent: Created child process 2108
[Tue Feb 28 10:24:00 2012] [notice] Disabled use of AcceptEx() WinSock2 API
[Tue Feb 28 10:24:01 2012] [notice] Digest: generating secret for digest authentication ...
[Tue Feb 28 10:24:01 2012] [notice] Digest: done
[Tue Feb 28 10:24:02 2012] [notice] Child 2108: Child process is running
[Tue Feb 28 10:24:02 2012] [notice] Child 2108: Acquired the start mutex.
[Tue Feb 28 10:24:02 2012] [notice] Child 2108: Starting 150 worker threads.
[Tue Feb 28 10:24:02 2012] [notice] Child 2108: Listening on port 443.
[Tue Feb 28 10:24:02 2012] [notice] Child 2108: Listening on port 80.
[Tue Feb 28 10:24:02 2012] [error] (OS 10038)An operation was attempted on something that is not a socket. : Too many errors in select loop. Child process exiting.
[Tue Feb 28 10:24:02 2012] [notice] Child 2108: Exit event signaled. Child process is ending.
[Tue Feb 28 10:24:03 2012] [notice] Child 2108: Released the start mutex
[Tue Feb 28 10:24:03 2012] [notice] Child 2108: All worker threads have exited.
[Tue Feb 28 10:24:03 2012] [notice] Child 2108: Child process is exiting
[Tue Feb 28 10:24:03 2012] [notice] Parent: child process exited with status 0 -- Restarting.
[Tue Feb 28 10:24:04 2012] [notice] Digest: generating secret for digest authentication ...
[Tue Feb 28 10:24:04 2012] [notice] Digest: done


I struck this problem a lot. Please help.
hooiyijun
 
Posts: 6
Joined: 25. February 2012 04:05
Operating System: -

Re: Cannot connect localhost

Postby hooiyijun » 05. March 2012 03:48

The solution is here. Yeah~
http://community.apachefriends.org/f/viewtopic.php?f=16&t=49599&p=191349#p191349
hooiyijun
 
Posts: 6
Joined: 25. February 2012 04:05
Operating System: -


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests