phpmyadmin not working [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpmyadmin not working [Solved]

Postby puma10 » 24. February 2012 23:41

Hey guys, I just installed xampp 1.7.7 and I having trouble getting phpmyadmin to work. When trying to access I get this error message "#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)". I install all programs on my slave drive (E:) to keep the operating system drive clear (C:). I installed xampp at E:\progam_files\. Xampp control panel says MYSQL is running. Also when typing localhost in the browser I get nothing but when typing the physical ip xampp/index.php loads.

Any ideas? Perhaps because I installed on a sub directory or on my slave disk.

Thanks so much in advance.
puma10
 
Posts: 3
Joined: 24. February 2012 23:34
Operating System: Windows 7

Re: phpmyadmin not working

Postby hackattack142 » 25. February 2012 00:19

You can try binding it to localhost as this sometimes fixes that issue.

Open your my.ini file (/xampp/mysql/bin/my.ini) and change
Code: Select all
#bind-address="127.0.0.1"

to
Code: Select all
bind-address="127.0.0.1"

and restart MySQL if it is running.

Now, make sure to also manually refresh that phpMyAdmin page so you do not load a cached error page.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: phpmyadmin not working

Postby puma10 » 25. February 2012 03:22

hackattack142, thank you for the quick response. I appreciate it, unfortunately it didn't work. Any other suggestions?
puma10
 
Posts: 3
Joined: 24. February 2012 23:34
Operating System: Windows 7

Re: phpmyadmin not working

Postby hackattack142 » 25. February 2012 05:00

Make sure your HOSTS file is correct for the localhost issue:
Open this file: C:\Windows\Sytem32\Drivers\etc\HOSTS

Then find the following line and remove the leading '#' character.

Code: Select all
    #   127.0.0.1       localhost

If it is not there then add that line without the hash as the first line after all the comments.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: phpmyadmin not working

Postby puma10 » 26. February 2012 01:59

PURE MAGIC. That solved the problem, thank you hackattack142! :D
puma10
 
Posts: 3
Joined: 24. February 2012 23:34
Operating System: Windows 7

Re: phpmyadmin not working [Solved]

Postby hubiedo » 06. June 2012 18:47

the first solution worked for me w/ win xp and new install of xammp. the second solution given above was already set up with the local host setting but it was entered twice and i removed one instance of it.

wow i appreciate the help
hubiedo
 
Posts: 1
Joined: 06. June 2012 18:34
Operating System: win xp pro


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests