Trouble uploading database [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Trouble uploading database [Solved]

Postby drtanz » 22. February 2012 01:51

Im receiving this error when trying to upload a compressed database. What can be the problem?

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 66580739 bytes) in F:\Web\Server\phpMyAdmin\libraries\zip_extension.lib.php on line 60
drtanz
 
Posts: 4
Joined: 21. June 2011 11:21

Re: Trouble uploading database

Postby JonB » 22. February 2012 01:57

In order to answer your question, it would be very useful to know what your OS and Version and your XAMPP version, please.

Please add them to your profile in the User Control Panel.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Trouble uploading database

Postby drtanz » 22. February 2012 10:30

Windows 7

###### ApacheFriends XAMPP version 1.7.7 ######

+ Apache 2.2.21
+ MySQL 5.5.16 (Community Server)
+ PHP 5.3.8 (VC9 X86 32bit thread safe) + PEAR
+ XAMPP Control Panel Version 2.5 from www.nat32.com
+ (BETA) XAMPP Control Panel Version 3.0.2 by Steffen Strueber (not in the USB & lite version)
see http://community.apachefriends.org/f/viewtopic.php?f=16&t=46743
+ XAMPP Security
+ OpenSSL 1.0.0e
+ phpMyAdmin 3.4.5
+ ADOdb 5.14
+ Mercury Mail Transport System v4.62 (not in the USB & lite version)
+ FileZilla FTP Server 0.9.39 (not in the USB & lite version)
+ Webalizer 2.23-04 (not in the USB & lite version)
+ Perl 5.10.1 (not in the USB & lite version)
+ Mod_perl 2.0.4 (not in the USB & lite version)
+ Tomcat 7.0.21 (not in the USB & lite version)
drtanz
 
Posts: 4
Joined: 21. June 2011 11:21

Re: Trouble uploading database

Postby JonB » 22. February 2012 16:46

Im receiving this error when trying to upload a compressed database. What can be the problem?

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 66580739 bytes) in F:\Web\Server\phpMyAdmin\libraries\zip_extension.lib.php on line 60


134,217,728 66,580,739 putting some commas in should help. The message is actually self-explanatory. The memory workspace that can be allocated for this process was exceeded. There are two solutions - research the parameters - you have hit a default PHP memory limit.

Google this term - "Fatal error: Allowed memory size of 134217728 bytes exhausted" you will find hundreds of hits

and work through them - you will find many recommend adding this to a script that is running into that limit:

ini_set('memory_limit', '-1'); overrides the default PHP memory limit. I don't know if this can be changed via php.ini, it may be a compilation option, Altrea would probably know.

or

Unzip the database first (much simpler)

BTW: about your version info -

"Please add them to your profile in the User Control Panel." this way the next time you ask a question, we don't have to do this.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Trouble uploading database

Postby Altrea » 23. February 2012 00:32

JonB wrote:I don't know if this can be changed via php.ini

Any value which is able to be setted with ini_set can be setted in the php.ini too i think. But not the other way round :)

JonB wrote:it may be a compilation option

It was a compilation option up to PHP 5.2.1. Nowadays (with current php versions) it is customizable by default.
http://www.php.net/manual/en/ini.core.p ... mory-limit

I would recommend to set this value back to normal after you have done your database upload. It is much easier to find memory leaks in your scripts with setted this value to a common value.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Trouble uploading database

Postby drtanz » 23. February 2012 00:48

Thanks guys I just used Navicat instead of PHPMyAdmin to import this particularly large database, problem sovled.
drtanz
 
Posts: 4
Joined: 21. June 2011 11:21


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests