[solved]php issue? please help

Problems with the Windows version of XAMPP, questions, comments, and anything related.

[solved]php issue? please help

Postby jillbuchanan » 14. February 2012 00:23

Hello,
I'm a newbie with this. I have installed xampp and can get to it through localhost, but I can't get my joomla test site to show.
when i go to localhost/sitename i get a message saying:
" You are using a server with PHP 5.3 outputting errors to the browser and reporting Strict Standards warnings. This combination does not allow Joomla' and its extensions to run properly. Most likely, you are using xampp released after januaryy 2011. You have the following options:
1. Edit your php.ini file and change the following lines:
error_reporting=E_ERROR
display_errors=0
2. INstall Zend Server CE with php 5.2, xampp 1.6.4 or any other server environment with php 5.2 )

So, I'm not sure if i found the right php file. It opens up as 'php notepad'. I can't seem to find anything I can open called php.ini other than that. I do find text that reflects what is written above but I'm not sure if i changed it correctly.
Is this where my problem is?
Can someone help a newbie who is about to rip her hair out? Thanks
jb
jillbuchanan
 
Posts: 2
Joined: 14. February 2012 00:14
Operating System: windows 7

Re: php issue? please help

Postby Altrea » 14. February 2012 05:01

Hi jillbuchanan,

First you should check, if your file extensions for known file types is hidden http://www.sevenforums.com/tutorials/10 ... -show.html
If that is the case, uncheck the checkfield to show all file extensions.

After that search again for your \xampp\php\php.ini file and open it.
Search for the line
Code: Select all
error_reporting = E_ALL | E_STRICT

it's around line ~516 of that file

change it to
Code: Select all
error_reporting = E_ALL


save the file and Joomla should work perfectly.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: php issue? please help

Postby jillbuchanan » 14. February 2012 15:40

This was extremely helpful- very thorough and detailed response which got me to the right places and helped me resolve my problems quickly. THANK YOU!!!
jillbuchanan
 
Posts: 2
Joined: 14. February 2012 00:14
Operating System: windows 7

Re: [solved]php issue? please help

Postby Altrea » 14. February 2012 16:54

Hi jillbuchanan,

Thank you for your feedback. I have marked your thread as solved.
I'm glad my information was helpful for you to solve your problem :D

Have fun with XAMPP and all that stuff.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 72 guests