Apache of xampp doesn't work, port 80 maybe in use [Solved]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache of xampp doesn't work, port 80 maybe in use [Solved]

Postby Kme » 13. February 2012 17:10

Update: Seems something in Adobe CS5 may have been consuming Port 80.
Not sure which specific start-up processes I UNCHECKED (about a half-dozen) but once I did so, Apache was functioning.
----
Cannot get Apache to run.
I did not uninstall Skype (but unchecked port 80/443 as backup ports).
I paused Kaspersky Anti-Virus incl Network tools during the install & afterward. (also granted all related Xampp & Apache modules FULL permissions)
Odd thing is, Xampp Apache DID work (same 1.77 version) on an earlier install.
Now only MySql is running.

Update: Installed the latest Control Panel (from v3.02 > 3.11) I get this error in the panel:
11:24:02 AM [main] Initializing Control Panel
11:24:02 AM [main] Windows Version: Windows 7 Professional SP1 64-bit
11:24:02 AM [main] XAMPP Version: 1.7.7
11:24:02 AM [main] Control Panel Version: 3.0.11 [ Compiled: December 7th 2011 ]
11:24:02 AM [main] You are not running with administrator rights! This will work for most application stuff but whenever you do something with services there will be a security dialogue or things will break! So think about running this application w/admin rights!
11:24:02 AM [main] XAMPP Installation Directory: "c:\xampp\"
11:24:02 AM [main] Initializing Modules
11:24:02 AM [apache] Possible problem detected!
11:24:02 AM [apache] Port 80 in use by "system"!
11:24:02 AM [main] Starting Check-Timer
11:24:02 AM [main] Control Panel Ready

I did restart the new Control Panel w/Admin Rights and still have an issue with Apache
...
11:28:28 AM [apache] Possible problem detected!
11:28:28 AM [apache] Port 80 in use by "system"!
11:28:28 AM [main] Enabling autostart for module "apache"
11:28:28 AM [main] Enabling autostart for module "mysql"
11:28:28 AM [main] Starting Check-Timer
11:28:28 AM [main] Control Panel Ready
11:28:29 AM [apache] Autostart active: starting...
11:28:29 AM [apache] Starting apache app...
11:28:29 AM [mysql] Autostart active: starting...
11:28:29 AM [mysql] Starting mysql app...
11:28:29 AM [mysql] Status change detected: running
11:28:35 AM [apache] Starting apache app...
Last edited by Kme on 13. February 2012 21:20, edited 7 times in total.
Kme
 
Posts: 9
Joined: 13. February 2012 17:03
Operating System: Win7x64 Sp1

Re: Apache of xampp doesn't work, port 80 may be in use

Postby Kme » 13. February 2012 17:36

Updated post#2 above to include control panel logs.
There were NO access or error logs. (I created them but they remained blank)
It's clear something is going wacky with port 80. (not sure how to correct the issue of Port 80 being used by "the system")
Kme
 
Posts: 9
Joined: 13. February 2012 17:03
Operating System: Win7x64 Sp1

Re: Apache of xampp doesn't work, port 80 may be in use

Postby JonB » 13. February 2012 17:55

@kme - I am splitting this topic - although you may SEEM to have the same problem, it does not follow you DO have the same issue - you have the same symptoms. Its next to impossible to debug two different machines with two different users :shock:

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache of xampp doesn't work, port 80 may be in use (KME

Postby JonB » 13. February 2012 18:00

I have suggested the tools needed in this nearly identical post:

viewtopic.php?f=16&t=49832

And have you run netstat before starting Apache??

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache of xampp doesn't work, port 80 may be in use (KME

Postby Kme » 13. February 2012 19:21

I tried w/o success to stop SYSTEM from running on port 80. (also wasn't able to Kill it in Process Explorer)
I also unchecked the IP6 feature on my network adapter. Still unable to get apache running.
Oh and "opened" Netstat BEFORE running apache.
Image
Image
Image
Kme
 
Posts: 9
Joined: 13. February 2012 17:03
Operating System: Win7x64 Sp1

Re: Apache of xampp doesn't work, port 80 may be in use (KME

Postby JonB » 13. February 2012 19:36

Two questions -

Before anything else - did you heed the comment about 'Run as Administrator' - you can use that with your XAMPP Control Panel shortcut.

A. by any chance are you running virtualization software like VMware, etc.?

B. Ok, you will never be able to kill System, LOL - look 'under System' for services - in particular for Microsoft Services. Many MS tools use a kludge to piggyback off IIS for their web interfaces. - look for http.sys being active.

You also might find the new Control Panel more pliable. - see the 'other thread' where I just posted that.

I need to check something on detecting the C libraries installed - was this machine 'reloaded' at any point?

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache of xampp doesn't work, port 80 may be in use (KME

Postby Kme » 13. February 2012 19:43

Yes I did run as ADMIN. (mentioned it in an edit in initial post).
No this was NOT a reloaded OS install. (however Xampp was reinstalled w/apache and mysql services)
Bumped into spec link below from your link and will see what it finds.
Thanx for the assistance. Will post up the results when I get them.
http://www.cameroncooke.com/2009/01/25/windows-7-uses-port-80-and-makes-it-impossible-to-install-apache-solution/
Kme
 
Posts: 9
Joined: 13. February 2012 17:03
Operating System: Win7x64 Sp1

Re: Apache of xampp doesn't work, port 80 may be in use (KME

Postby Kme » 13. February 2012 19:48

Trying this suggestion below from "Cameron" from the link above. Will reboot and see.
You have to disable the http.sys service manually via the registry:
1) Launch RegEdit:
2) Go to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\HTTP
3) Add a new DWORD (32-bit) value
4) Name it ‘NoRun’ not including the quotes
5) Double click the new property
6) In the Value data field type ’1′ not including quotes and click OK
7) Re-boot your computer
You should now find that Apache will start on port 80!
Kme
 
Posts: 9
Joined: 13. February 2012 17:03
Operating System: Win7x64 Sp1

Re: Apache of xampp doesn't work, port 80 may be in use (KME

Postby JonB » 13. February 2012 20:02

OK, that's headed in the right direction, - so http.sys was running, correct???

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache of xampp doesn't work, port 80 may be in use (KME

Postby Kme » 13. February 2012 20:08

The RegEdit tweak did NOT work. :-(
I booted into safe mode w/networking and WAS able to get Apache running. (though not MySQL).
This certainly seems like an issue with "system" using that Port 80 / PID 4.
NetStat did not show port 80 being used while running OS in safe mode.
---
Update as mentioned in edited OP - disabling some Adobe CS5 apps (acro tray, etc) at start-up allowed me to recover use of Port 80.
Kme
 
Posts: 9
Joined: 13. February 2012 17:03
Operating System: Win7x64 Sp1

Re: Apache of xampp doesn't work, port 80 may be in use (KME

Postby JonB » 13. February 2012 21:49

OK - so this was an "Adobe issue" as best we can tell - correct??

(BTW, all services, no matter whose they are, use Services.exe)

This is the Services Control Manager, which is responsible for running, ending, and interacting with system services. Use this program to start services, stop them, or change their default from automatic to manual startup.

So in Process Explorer, you will see your Apache httpd.exe running in that System Tree, as (if you have made it a service) it gets launched with the System, thus you don't have to be logged in for it to run. (that's the flipside of 'run as')

That's why I told you (or the other one) to hunt in Process Explorer under System (which is always Process ID 4)

Please do us all a favor, and don't top post, as people don't go back to read the original (including the volunteers) :wink: Threads can get long. .

Good Luck now, and I am glad you have it working.
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache of xampp doesn't work, port 80 maybe in use [Solv

Postby trytohelp » 21. September 2012 01:24

change the number 80 in httdp.conf to 8000. You should change the number 80 in the whole document in order apache to work. And when you try to go to the xampp in the broswer you should type http://lpcalhost:8000. I hope this will help
trytohelp
 
Posts: 1
Joined: 21. September 2012 01:07
Operating System: windows 7 ultimate x64

Re: Apache of xampp doesn't work, port 80 maybe in use [Solv

Postby JonB » 21. September 2012 01:39

@ trytohelp -

Read carefully please - the OP solved the problem: :shock:

Update as mentioned in edited OP - disabling some Adobe CS5 apps (acro tray, etc) at start-up allowed me to recover use of Port 80.


Good Luck
8)



ysf
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 76 guests