changing port blocks everything

Problems with the Windows version of XAMPP, questions, comments, and anything related.

changing port blocks everything

Postby alain.roger » 03. February 2012 22:24

Hi,

i'm new to xampp however i already worked with apache/php/mysql.
i have some trouble testing xampp 1.7.7 under windows 7.

basically i didn't change anything to configuration files except the listening port.
instead of using 80 i use 10080.
so for that i changed httpd.conf from c:\xampp\apache\conf\ at 2 places.
Code: Select all
Listen localhost:10080
ServerName localhost:10080

when i do that and restart server, only phpMyBackupPro works when i launch http://localhost:10080
nothing more.
the standard localhost/xampp/index.php stopped to work (i get an error 404:The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.)

later i would like to setup some virtualhost as following
Code: Select all
NameVirtualHost *:10080

#--------------------------
# Test plateform Joomla 2.5
#--------------------------
<VirtualHost *:10080>
  DocumentRoot "d:/webserver/www/jtest25"
  ServerName jtest25.loc
  ServerAlias www.jtest25.loc
  ErrorLog "logs/jtest25.loc.error.log"
  CustomLog "logs/jtest25.loc.access.log" common
 
    <Directory "d:/webserver/www/jtest25/">
      AllowOverride AuthConfig FileInfo
      Order deny,allow
      Deny from all
      Allow from 127.0.0.1
    </Directory>
     
</VirtualHost>


all those settings work correctly under standard web server(apache/php/mysql) so i don't understand where is the problem now.
could you tell me if something special must be done ?

i searched on internet and i didn't find anything particular (i have no other services running with 10080 port)

thx.
What does not kill you, makes you stronger

RogTek, Web agency: htttp://www.rogtek.com
facebook: http://www.facebook.com/rogtek
User avatar
alain.roger
 
Posts: 13
Joined: 03. February 2012 22:14
Operating System: Kubuntu 15.10

Re: changing port blocks everything

Postby Altrea » 04. February 2012 09:58

Hi alain.roger,

alain.roger wrote:
Code: Select all
Listen localhost:10080

This setting is not correct. Processes don't listen on DomainNames, but on IPs and/or ports.
Code: Select all
//wrong
Listen localhost:10080

//correct
Listen 10080

//correct
Listen 127.0.0.1:10080


alain.roger wrote:the standard localhost/xampp/index.php stopped to work (i get an error 404:The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.)

I have changed my port too for testing and my orange XAMPP Administration Page works like a charme, as before.
Every HTTP 404 status error will be written to your \xampp\apache\logs\error.log file.
Take a look into this for more information.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 39 guests