Can't change Apache Port

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't change Apache Port

Postby JosephDuffy » 01. February 2012 18:44

Hi,
I am trying to change the port Apache uses, from 80, to something like 81 or 1000.
I have gone into the httpd.conf and changed "listen 80" to "listen 81", along with "localhost:80" to "localhost:81". I have saved these changes and rebooted the PC. Apache does not start, and when I go into the control panel and start it, I just get "starting...", but it never does.
Any ideas would be great! :)
JosephDuffy
 
Posts: 3
Joined: 01. February 2012 18:40
Operating System: WHS 2011

Re: Can't change Apache Port

Postby Altrea » 01. February 2012 23:34

Hi JosephDuffy,

Have you ticked the svc buttons?
If yes, try to untick them first. Running the components as service can end in errors you never had without the services.

Then take a look into your \xampp\apache\logs\error.log. All starting attempts (and possible errors) will be logged there.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 59 guests