Page 1 of 1

XAMPP USB Lite 1.7.7 broken [SOLVED]

PostPosted: 22. January 2012 00:23
by frankyboy123
I have been using an old version of XAMPP for quite some time with much joy. However, I have just tried to download version 1.7.7 for my home laptop computer (XP Home SP3) and ran into problems. I only want the LITE version as I have no need for the extra packages so I downloaded the 7zip version.

Upon trying to start Apache it fails with an an error on line 458 of the httpd.conf file:
Code: Select all
Include "conf/extra/httpd-perl.conf"

This is quite right as the 'httpd-perl.conf' file does not exist. After commenting out that line it starts up okay but the XAMPP index page displays several errors which probably shouldn't be there. They are concerned with lines 111 and 112 or the 'navi.php' page:
Code: Select all
<?php include ""; ?>
<?php include ""; ?>

Again, these files are missing from the installation.

Also, MySQL just does not start at all. There are no errors logged - in fact no log file at all. It simply says:
Code: Select all
MySQL konnte nicht gestartet werden
MySQL could not be started

It is using 'mysql\bin\my.ini' for its configuration which all looks okay as far as I can tell. I have no idea why that isn't starting but I am very disappointed with this version of XAMPP so far.

On an unrelated note, I had great difficulty registering to use this forum. My home email account is an address at which appears to be unacceptable by your phpBB installation. I got no error message telling me this it just kept returning me to the registration page. It was only through trial and error that I found it was the email address that was causing it to fail so I had to use a work email address instead.

Re: XAMPP USB Lite 1.7.7 broken

PostPosted: 22. January 2012 00:37
by frankyboy123
I have just looked into this a little more and it would appear there are entries in the 7zip file for those missing configuration files (and a few more) but they cannot be extracted. They are listed as having a file size of 0 and a CRC of 00000000. I have tried downloading it again to be sure but get the same results. It looks like it might just be a corrupt 7zip file you have on the SourceForge server.

Just downloaded the ZIP version of the package and it still has those same files flagged as 0 bytes but it does extract them and everything appears to work now.

Re: XAMPP USB Lite 1.7.7 broken

PostPosted: 22. January 2012 01:01
by Sharley
No they are needed zero length files and your extract utility is not extracting them from the 7zip file.

Try changing your extract utility IZArc to the freeware 7zip utility and your problem will be solved.

This issue was posted about and investigated previously with the archiver IZArc being the problem and 7zip was the solution found to work as it should.

After reading your update I will close this topic and mark it solved.

Please start a new topic if you have any more issues with XAMPP.

Good luck. :)