Xamp 1.7.7

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xamp 1.7.7

Postby arkadios » 20. January 2012 11:49

Hello.
my system is windows 7 64 bit with comodo personal firewall.
today i try to install xamp 1.7.7 , on the final step when i press thsstart button of apache server
its not working and says
apache startd ( port 80 )
i scan my system and the 80 is not in use
i try to change the 80 with 8080 on httpd.conf and on xamp.ini but still exist the problem.
i put the apache application as a trust appl on comodo but still have problem.
a
arkadios
 
Posts: 3
Joined: 20. January 2012 11:34
Operating System: windows 7 64 bit

Re: Xamp 1.7.7

Postby Sharley » 20. January 2012 11:55

Did you install XAMPP 1.7.7 into the C:\ drive so you have C:\xampp as the installation folder?

Can you use the new version 3 Control Panel found in the XAMPP folder:
xampp-control-beta-3.exe
as it has a better log window that gives more detail.
First Exit the older version 2.5 after Stopping any XAMPP components you may have running.

Also this new version has a Netstat button that may tell if there is anything using port 80.

For the latest version the download is linked to in my signature 'Control Panel Version 3' button tab.
Simply extract all the files and folders from the CPv3 folder found in the archive to the xampp installation folder and overwrite when asked.
Then right click the exe to create a shortcut to the desktop, for example, for easier access.

This version 3 (XCPv3) control panel has many new features including a much more detailed log window to help with troubleshooting start issues.


Also please read the \xampp\apache\logs\error.log file for clues why Apache can't start.

If you don't see any log files in that log folder then you may need to read on.
XAMPP for Windows 1.7.7 is compiled using VC9 (Visual C++ SP1) and so the runtime file (Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)) is needed and can be downloaded then installed using this Microsoft link which also contains full information:
http://www.microsoft.com/download/en/de ... px?id=5582

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Xamp 1.7.7

Postby arkadios » 20. January 2012 12:16

FOR THE APACHE SAYS POSSIBLE PROBLEM DETECTED: PORT 80 IN USE BY SYSTEM
arkadios
 
Posts: 3
Joined: 20. January 2012 11:34
Operating System: windows 7 64 bit

Re: Xamp 1.7.7

Postby Sharley » 20. January 2012 13:14

Please do not use all capital letters, it is deemed to be shouting in a forum and I don't think you meant to shout.
http://forum-services-review.toptenrevi ... -tips.html


You may have not disabled the default Windows web server IIS Internet Information Service (aka World Wide Publishing).

To make sure that IIS is disabled these links may help:
viewtopic.php?p=175526#p175526
viewtopic.php?p=186588#p186588
http://forums.iis.net/p/1150139/1872824.aspx
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Xamp 1.7.7

Postby arkadios » 20. January 2012 13:30

Im very sorry for the capital.
So to my problem. No im not running IIS
2:08:37 μμ [apache] Possible problem detected: Port 80 in use by "system"!
2:08:37 μμ [apache] Possible problem detected: Port 443 in use by "vmware-hostd.exe"!
this is what i see when ui try to start apache.
arkadios
 
Posts: 3
Joined: 20. January 2012 11:34
Operating System: windows 7 64 bit

Re: Xamp 1.7.7

Postby Sharley » 20. January 2012 13:36

You will have to disable anything that is using port 80 and port 443 or Apache can't start.

I have given you clues and links for IIS so now you will have to investigate what you have running on your PC that is using the above ports and either have them use other ports or disable them.

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Xamp 1.7.7

Postby JJ_Tagy » 30. January 2012 13:46

The reason it won't start is because you have shared VMs active in vmware. You should change disable shared VMs. If you need to use shared VMs, then just change the port away from 443.
JJ_Tagy
 
Posts: 678
Joined: 30. January 2012 13:44
Operating System: Windows 10 Pro x64

Re: Xamp 1.7.7

Postby JonB » 30. January 2012 16:10

Good Call :shock: - jj_tagy

:mrgreen:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests