SSI greater 255 Bytes prevents loading of remaining text

Problems with the Windows version of XAMPP, questions, comments, and anything related.

SSI greater 255 Bytes prevents loading of remaining text

Postby tinker8 » 18. January 2012 14:39

I just installed xampp 1.7.7 on to my Windows XP SP3 system to test server functions like Server Side Includes SSI, etc..

I am able to load and display the content of my include file "navigation.inc"
Code: Select all
<div>
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789
0123456789

</div>

in my document Test.shtml:
Code: Select all
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta content="text/html; charset=ISO-8859-1" http-equiv="content-type"><title>Test</title>
</head>
<body style="margin-top: 1px; margin-left: 0px;">
<h1>Including File</h1>
<!--#include virtual="navigation.inc" -->
<div id="Text" style="margin-left: 100px; margin-right: 100px;">
<h1>Lorem Ipsum</h1>
<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit.
</p>
</div>
&nbsp;
</body>
</html>

But when the size of the include file is larger than 255 bytes - just adding 1 character, the text following
the include will not be shown anymore.

Is there a configuration option, which I have to set to enable include files larger than 255 bytes?

BTW: when I upoload the shtml and the include file to my web space using my web hosting service, it is possible to include larger files.
tinker8
 
Posts: 1
Joined: 18. January 2012 13:56
Operating System: Windows XP SP 3

Re: SSI greater 255 Bytes prevents loading of remaining text

Postby Sharley » 18. January 2012 20:52

I just tried to reproduce your problem and even after adding characters so the value of the Test.shtml was 5000 bytes the file displayed correctly.

I simply copied and pasted the div in the navigation.inc and added more text in other divs and no problem with display at all.

There is no configuration I am aware of to set the number of characters to display in shtml files.

My test bed was exactly the same as yours - see my profile display.

Perhaps it may be a browser issue, try clearing your browser's cache from time to time when working at localhost.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests