Can't start apache [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't start apache [SOLVED]

Postby z080236 » 17. January 2012 03:11

I can't start apache on xampp control panel, and also can't start using bat file
when i check port i found this:
Service:Apache port:8080 Status:Process:System

I can't uninstall it either, may i know what i need to do

btw, i already stopped IIS when i did start apache

and i also can't uninstall it, do i have to delete the whole folder and reinstall it again?
z080236
 
Posts: 10
Joined: 18. March 2011 17:24
Operating System: Windows Vista

Re: Can't start apache

Postby Sharley » 17. January 2012 03:28

Would you be so kind as to add your XAMPP version and Operating System to your profile as per these instructions and associated information:
viewtopic.php?f=16&t=48626
Thanks. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't start apache

Postby z080236 » 17. January 2012 16:11

Sharley wrote:Would you be so kind as to add your XAMPP version and Operating System to your profile as per these instructions and associated information:
http://community.apachefriends.org/f/viewtopic.php?f=16&t=48626
Thanks. :)

i have already added, it's ver 1.7.3, with windows vista

i keep getting this message in command prompt when i tried to uninstall it, should i just delete the whole xampp folder?

Microsoft Windows [Version 6.0.6002]
Copyright (c) 2006 Microsoft Corporation. All rights reserved.


C:\xampp>run apache_start.bat
'run' is not recognized as an internal or external command,
operable program or batch file.

C:\xampp>uninstall_xampp.bat
'CSCRIPT.EXE' is not recognized as an internal or external command,
operable program or batch file.

XAMPP uninstall not OK

Press any key to continue . . .
z080236
 
Posts: 10
Joined: 18. March 2011 17:24
Operating System: Windows Vista

Re: Can't start apache

Postby z080236 » 17. January 2012 16:53

i deleted everything and reinstalled the new version, yet i can't run apache from the control panel
z080236
 
Posts: 10
Joined: 18. March 2011 17:24
Operating System: Windows Vista

Re: Can't start apache

Postby z080236 » 17. January 2012 17:05

Windows Operating System; Version: 6.0.6001.18000; Event ID: 3299; Event Source: Apache Service;
this is what i got for event viewer
z080236
 
Posts: 10
Joined: 18. March 2011 17:24
Operating System: Windows Vista

Re: Can't start apache

Postby Sharley » 18. January 2012 01:20

i deleted everything and reinstalled the new version
So now you are trying to install and use XAMPP 1.7.7 is that correct?

You may have to log into Vista as an administrator to work with XAMPP.

Right clicking on files and selecting to run as an admin may also help.

You may like to also try uninstalling/installing using a different method by downloading the zip or 7zip version found in these instructions:
viewtopic.php?p=179699#p179699

The zip or 7zip archive files for a particulat version can be found here:
SourceForge XAMPP File Repository

If you look in the xampp\apache\logs folder and find there are no log files after trying to start Apache in 1.7.7 then you could be missing the VC9 runtime file.

XAMPP for Windows 1.7.7 is compiled using VC9 (Visual C++ SP1) and so the runtime file (Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)) is needed and can be downloaded then installed using this Microsoft link which also contains full information:
http://www.microsoft.com/download/en/de ... px?id=5582

Best wishes. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't start apache

Postby z080236 » 19. January 2012 04:24

Sharley wrote:
i deleted everything and reinstalled the new version
So now you are trying to install and use XAMPP 1.7.7 is that correct?

You may have to log into Vista as an administrator to work with XAMPP.

Right clicking on files and selecting to run as an admin may also help.

You may like to also try uninstalling/installing using a different method by downloading the zip or 7zip version found in these instructions:
http://community.apachefriends.org/f/viewtopic.php?p=179699#p179699

The zip or 7zip archive files for a particulat version can be found here:


If you look in the xampp\apache\logs folder and find there are no log files after trying to start Apache in 1.7.7 then you could be missing the VC9 runtime file.

XAMPP for Windows 1.7.7 is compiled using VC9 (Visual C++ SP1) and so the runtime file (Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)) is needed and can be downloaded then installed using this Microsoft link which also contains full information:
http://www.microsoft.com/download/en/details.aspx?id=5582

Best wishes. :)

when i check port i found this:
Service:Apache port:80 Status:Process:System

that's not the problem, something on my system is occupying port 80, preventing it from working, can u show how to free the port 80?
z080236
 
Posts: 10
Joined: 18. March 2011 17:24
Operating System: Windows Vista

Re: Can't start apache

Postby Sharley » 19. January 2012 06:50

Try these posts and see if there is a solution for you, remember that simply stopping IIS is not enough, you have to disable it and there are links to instruction how to do this.
viewtopic.php?p=179699#p179740
viewtopic.php?f=16&t=49534#p191058
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't start apache

Postby z080236 » 01. February 2012 17:50

Sharley wrote:Try these posts and see if there is a solution for you, remember that simply stopping IIS is not enough, you have to disable it and there are links to instruction how to do this.
http://community.apachefriends.org/f/viewtopic.php?p=179699#p179740
http://community.apachefriends.org/f/viewtopic.php?f=16&t=49534#p191058


i tried this, but it port 80 is still occupied by system
z080236
 
Posts: 10
Joined: 18. March 2011 17:24
Operating System: Windows Vista

Re: Can't start apache

Postby z080236 » 01. February 2012 18:05

ok, i went and stopped the web deployment service in services
works fine now
z080236
 
Posts: 10
Joined: 18. March 2011 17:24
Operating System: Windows Vista

Re: Can't start apache

Postby Sharley » 01. February 2012 23:20

Thanks for the feedback. 8)

I will close this topic and mark it solved.

Please feel free to start a new topic if you have any more issues with XAMPP for Windows.

Best wishes. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 61 guests