Can't start PHP [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: Can't start PHP

Postby MTG » 17. January 2012 05:13

After I reinstall, it prompts like this. The service was not install. I only install on control panel,when I click on start.
8:07:43 PM [main] Executing "services.msc"
8:08:01 PM [apache] Installing service...
8:08:14 PM [apache] There may be an error, return code: 14001 - This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.
8:08:14 PM [apache] Service was NOT (un)installed!
8:08:14 PM [apache] One possible reason for failure: On windows security box you !!!MUST UNCHECK!!! that "Protect my computer and data from unauthorized program activity" checkbox!!!
8:08:50 PM [apache] Installing service...
8:08:59 PM [apache] There may be an error, return code: 14001 - This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.
8:08:59 PM [apache] Service was NOT (un)installed!
8:08:59 PM [apache] One possible reason for failure: On windows security box you !!!MUST UNCHECK!!! that "Protect my computer and data from unauthorized program activity" checkbox!!!
MTG
 
Posts: 17
Joined: 13. January 2012 09:28
Operating System: xp service pad3

Re: Can't start PHP

Postby Sharley » 17. January 2012 07:14

When a reference to 'service' is mentioned this means the Windows Service that will install/uninstall an XAMPP Windows Service component when you boot your PC and is not required for most developers who prefer to stop and start the XAMPP components manually.

It does not mean start and stop an XAMPP component as the Stop/Start buttons in the control panel do that manually.

So when you uninstalled following the instructions I posted did you uncheck the Svc boxes in the old 2.5 CP or the green ticks in the new XCPv3 that would have uninstalled the Windows Services?

Do you now have a green tick in any of the Modules Services column in the XCPv3 control panel?

If so click on them to select and then when asked click on yes to remove the Windows Service.

You will need to then uncheck the box in the Run As window next to
"Protect my computer and data from unauthorized program activity"
as mentioned in the XCPv3 log window in your last post.

Once the green ticks have been removed you should be able to click on the Start button next to the XAMPP components Apache and MySQL which will light up in green the name under the Module column.

BTW, did you download and extract all the files and folder of the latest XCPv3 control panel?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't start PHP

Postby MTG » 17. January 2012 19:03

Yes, I did turn off the service check before I installed.
I also unchecked from Admin "Protect my computer and data from unauthorized program activity"
When I opened the control panel, I have different set of error. My control panel is running on v3.0.11
All services check was marked "X"
---------------------------------------------------------------------
9:41:25 AM [filezilla] Run this program from your XAMPP root directory!
9:41:25 AM [mercury] Possible problem detected: Mercury Not Found!
9:41:25 AM [mercury] Run this program from your XAMPP root directory!
9:41:25 AM [tomcat] Possible problem detected: Tomcat Not Found!
9:41:25 AM [tomcat] Run this program from your XAMPP root directory!
9:41:25 AM [main] Starting Check-Timer
9:41:25 AM [main] Control Panel Ready
-----------------------------------------------------------------------
I check the root file, c:/xammp/CPV3, inside CPV3 folder has 2 folders (Locale & Xcp3src) ,
4files (Catalina_service.bat,Catalina_start.bat,Catalina_stop.bat,
Xammp-control-3beta10.exe,Xammp-control-3beta10.log,Xammp-control-3beta10.ini)

My appache folder is under Xammp
c:/xammp/appache, Appache folder has lot of files, including bin
Same arrangement as MysqL, filezilla

At the root c:/xammp/ , I have 3 duplicate files as CPV3 folder, such as:
Xammp-control-3beta10.exe,
Xammp-control-3beta10.log,
Xammp-control-3beta10.ini
MTG
 
Posts: 17
Joined: 13. January 2012 09:28
Operating System: xp service pad3

Re: Can't start PHP

Postby MTG » 18. January 2012 00:59

What's your suggestion? I can move folders and files from CPV3 to C:/xammp
MTG
 
Posts: 17
Joined: 13. January 2012 09:28
Operating System: xp service pad3

Re: Can't start PHP

Postby Sharley » 18. January 2012 01:06

The XCPv3 files must be in the C:\xampp folder not in the C:\xampp\CPv3 folder..

You need to open the archive that contains the CPv3 files and then click on the folder CPv3 to open it then drag all the files and folders you see in that folder into C:\xampp then overwrite when asked - do not drag or copy the CPv3 folder or you will get the same errors as you posted in the above log window, which by the way is the contents of the xampp-control-3-beta10.ini file.

You can then delete the CPv3 folder in the C:\xampp folder as it is no longer needed.

Now you can double click on the xampp-control-3-beta10 and check the log window again for any issues and paste the content here or simply try and Start Apache and MySQL.

If they start then you can click on the Apache Admin button, select your language and then exercise all the demos in the left menu frame to check your installation is working correctly.

At this stage you should only Start Apache and MySQL and nothing else until your XAMPP installtion is in a known correct state.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't start PHP

Postby MTG » 18. January 2012 01:38

Got it. You are a life saver.
MTG
 
Posts: 17
Joined: 13. January 2012 09:28
Operating System: xp service pad3

Re: Can't start PHP

Postby Sharley » 18. January 2012 01:49

MTG wrote:Got it. You are a life saver.
That's good news that the XCPv3 is finally working for you.

Now let's see what the log window has to say about your issues now after it is loaded.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

httpd.exe missing

Postby MTG » 18. January 2012 02:10

I followed the instruction, it works OK, until I open the control panel,
--------------------------------------------------------------------------------
4:56:01 PM [main] Initializing Control Panel
4:56:01 PM [main] Windows Version: Windows XP SP3 32-bit
4:56:01 PM [main] XAMPP Version: 1.7.7
4:56:01 PM [main] Control Panel Version: 3.0.11 [ Compiled: December 7th 2011 ]
4:56:01 PM [main] Running with Administrator rights - good!
4:56:01 PM [main] XAMPP Installation Directory: "c:\xampp\"
4:56:01 PM [main] Initializing Modules
4:56:01 PM [main] Starting Check-Timer
4:56:01 PM [main] Control Panel Ready
4:56:25 PM [apache] Starting apache app...
4:56:39 PM [apache] Installing service...
4:56:49 PM [apache] There may be an error, return code: 14001 - This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.
4:56:49 PM [apache] Service was NOT (un)installed!
-----------------------------------------------------------------------------------
Apache was not working since the beginning, mysql works fine.
MTG
 
Posts: 17
Joined: 13. January 2012 09:28
Operating System: xp service pad3

Re: httpd.exe missing

Postby Sharley » 18. January 2012 02:14

Have a look in the C:\xampp\apache\logs folder for the error.log file.

If the folder is empty then Apache has never started and you may be missing the VC9 runtime file as indicated by this message
Code: Select all
4:56:49 PM [apache] There may be an error, return code: 14001 - This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.
in the control panel log window - that 14001 message is generated by the Windows system not the control panel, it is just passing on that message it received and as usual Windows system messages are usually meaningless to most people. :shock:

XAMPP for Windows 1.7.7 is compiled using VC9 (Visual C++ SP1) and so the runtime file (Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)) is needed and can be downloaded then installed using this Microsoft link which also contains full information:
http://www.microsoft.com/download/en/de ... px?id=5582

Please let me know back if this fixes your issue and Apache is able to finally start.

Best wishes. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't start PHP

Postby MTG » 20. January 2012 04:39

Apache is finally running. Now MysqL is not working.
-----------------------------------------------------------------------
7:22:55 PM [apache] Starting apache service...
7:23:00 PM [apache] Status change detected: running
7:23:12 PM [mysql] Installing service...
7:23:18 PM [mysql] Status change detected: running
7:23:18 PM [mysql] Service was NOT (un)installed!
7:23:18 PM [mysql] One possible reason for failure: On windows security box you !!!MUST UNCHECK!!! that "Protect my computer and data from unauthorized program activity" checkbox!!!
7:23:19 PM [mysql] Status change detected: stopped
7:23:22 PM [mysql] Starting mysql service...
7:23:27 PM [mysql] Status change detected: running
----------------------------------------------------------------------------
******After I uninstalled MysqL service, I just start without activating the service.
------------------------------------------------------------------------------------
7:23:18 PM [mysql] One possible reason for failure: On windows security box you !!!MUST UNCHECK!!! that "Protect my computer and data from unauthorized program activity" checkbox!!!
7:23:19 PM [mysql] Status change detected: stopped
7:23:22 PM [mysql] Starting mysql service...
7:23:27 PM [mysql] Status change detected: running
7:28:25 PM [mysql] Stopping mysql service...
7:28:30 PM [mysql] Status change detected: stopped
7:28:36 PM [mysql] Uninstalling service...
7:28:42 PM [mysql] Starting mysql app...
7:28:42 PM [mysql] Status change detected: running
------------------------------------------------------------------
Is it OK to run without activate MysqL service?
MTG
 
Posts: 17
Joined: 13. January 2012 09:28
Operating System: xp service pad3

Re: Can't start PHP

Postby Sharley » 20. January 2012 04:55

MTG wrote:Is it OK to run without activate MysqL service?
Yes it is and it is my preferred method. I never run Apache or MySQL or in fact any XAMPP components as a Windows Service.

The Service is the MySQL Windows Service that starts MySQL after a boot and so is not required for normal development use - best starting it manually in the control panel by using the Start button not by clicking on the Service box.

I am pleased you can start Apache at last. :)

I hope after uninstalling (removing) the MySQL Windows Service that you can also Start MySQL from the Control Panel. ;)
Code: Select all
7:23:18 PM [mysql] One possible reason for failure: On windows security box you !!!MUST UNCHECK!!! that "Protect my computer and data from unauthorized program activity" checkbox!!!
You must also follow this instruction when you get the Run As... windows to successfully remove the green tick and the Apache and MySQL Windows Service - it is safe to do so as it will be returned to the default afterwards.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Can't start PHP

Postby MTG » 20. January 2012 23:01

Thank you for your patient!
Apache;Mysql and Filezilla are running. What's next?
Can I delete one of the old control panel (v.3.02) includes Logs and ini?
Now, I can install Wordpress.
MTG
 
Posts: 17
Joined: 13. January 2012 09:28
Operating System: xp service pad3

Re: Can't start PHP

Postby Altrea » 20. January 2012 23:10

Hi MTG,

MTG wrote:Can I delete one of the old control panel (v.3.02) includes Logs and ini?

Yes, you can if you wish. The control panel is pretty much standalone.
Make sure, the control panel you wish to delete isn't running anymore before you try to delete it.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Can't start PHP

Postby Sharley » 21. January 2012 02:00

MTG wrote:Thank you for your patient!
Apache;Mysql and Filezilla are running. What's next?...
...Now, I can install Wordpress.
Thanks for the feedback and I am pleased you can move on and install WordPress.

If you have any WordPress issues they will be best addressed in the WordPress forums.



I will close this topic now and mark it solved.

Please feel free to start a new topic if you have any more issues with XAMPP for Windows.

Good luck and my best wishes. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests