404 error and blocked ports [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

404 error and blocked ports [SOLVED]

Postby FrankZ » 02. January 2012 05:43

I'm not an IT guy so bare with me please.

I''m trying to install XAMPP and have been getting the following messages during installation of version 1.7.4 on my Win7 pc

Port 80 or 443 (SSL) already in use. Installing Apache 2.2 service failed

Port 3306 Already in use. Installing mySQL service failed.

XAMPP Component status check failure [3].

I finally found this as well:
[Ports]
Port80=BLOCKED
Port443=FREE
Port3306=BLOCKED
Port21=FREE
Port14147=FREE
Port8080=FREE

So how do I unblock these ports so I can use XAMPP?
FrankZ
 
Posts: 5
Joined: 02. January 2012 05:09
Operating System: Win7

Re: 404 erro and blocked ports

Postby Sharley » 02. January 2012 05:46

Your profile says you are using 1.7.7 do you mean 1.7.7 or 1.7.4?

You can correct your profile by following these instructions:
viewtopic.php?f=16&t=48626


If you are trying to install 1.7.4 then please be aware that there were many issues related to this particular version and they were recorded here:
viewtopic.php?f=16&t=44327

There are also a few conflicting statements in your post - one is saying port 80/443 are in use where as the other is saying 443 is FREE.


A 404 error means that a file can't be found.


The status check failure (just one of the 1.7.4 issues) can be ignored or rectified by finding a solution in this topic.
viewtopic.php?f=16&t=44320

Have you tried to install another version of XAMPP previous to attempting to install this version?

The ports in use usually mean you have not uninstalled the Apache and MySQL Windows services before unstalling XAMPP again if you have tried to uninstall a few times..

You do that by removing the tick in the Svc check box before stopping Apache and MySQL then you Exit the control panel.

These instructions may help if you are uninstalling and reinstalling XAMPP:
viewtopic.php?p=179699#p179699
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: 404 erro and blocked ports

Postby FrankZ » 02. January 2012 14:17

Thanks for replying.
I've tried both 7.4 and 7.7
Can't get either version to work properly.
Yes i can see the control panel but i still get the 404 error message.

Most recently I've uninstalled and attempted to delete XAMPP but am left with G:\XAMPP that I cannot delete no matter what I do. I've attempted unstalling with the XAMPP UNINSTALL program and via Control Panel with the same end result.

How do I get rid of it?
FrankZ
 
Posts: 5
Joined: 02. January 2012 05:09
Operating System: Win7

Re: 404 erro and blocked ports

Postby FrankZ » 02. January 2012 15:25

Saw this on the FAQ;
Shut down all XAMPP servers and exit all panels. If you installed any services, uninstall and shut them down too. Now simply delete the entire folder where XAMPP is installed. There are no registry entries and no environment variables to clean up... just simply good, clean code!


Love to...but can't.

Google search turned up others with the same issue. I've seen a few people say you have to shut down the services. Well that's wonderful if you still have XAMPP installed but I don't. So whats the solution?

How in the heck am I supposed to remove the folder if I no longer have the program installed to shut down a program(s) that should have been removed during the UNINSTALL process? :roll:
FrankZ
 
Posts: 5
Joined: 02. January 2012 05:09
Operating System: Win7

Re: 404 erro and blocked ports

Postby Sharley » 02. January 2012 19:33

The folder will not delete if there are files in use and usually that means the Windows services of Apache and MySQL.

Look in the Windows Task Manager usually found by right clicking on the Task Bar and selecting it then click on the Processes tab and look for httpd.exe (2 instances) and mysqld.exe and select to kill those processes. Answer yes to the question and then close the Task Manager.

You hopefully will be able to delete the xampp folder.

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: 404 erro and blocked ports

Postby FrankZ » 02. January 2012 21:56

I looked in the task manager and searched my PC for httpd.exe, no instances found.

I closed 3 processes relating to XAMPP and was able to delete G:\XAMPP

Downloaded the .Zip version and installed it.
Apache won't start, Port 80 is in use by "system".

Back to square one...
FrankZ
 
Posts: 5
Joined: 02. January 2012 05:09
Operating System: Win7

Re: 404 erro and blocked ports

Postby Sharley » 02. January 2012 22:06

Did you try a reboot, often this may fix this System issue.

Something is still using port 80 and it may be a registry entry for the Windows Apache service.

Again check the Task Manager.

Just to recap what version of XAMPP are you trying to start?

If 1.7.7 then you could use the version 3 control panel found in the xampp installation folder:
xampp-control-3-beta.exe
The latest version download link is in my signature.
Simply extract all the files from the archive to the xampp installation folder and overwrite when asked.
Then right click the exe file to run as administrator and to create a shortcut to the desktop, for example, for easier access.

Look for a green tick in the services column of Apache and if it is there try removing it by clicking on it.

If you can remove it then try and start Apache.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: 404 erro and blocked ports

Postby FrankZ » 02. January 2012 22:44

this seems to have done the trick!!
http://community.apachefriends.org/f/viewtopic.php?p=179699#p179740

Thanks for the assistance!
7.7 is up and running!!
FrankZ
 
Posts: 5
Joined: 02. January 2012 05:09
Operating System: Win7

Re: 404 erro and blocked ports

Postby Sharley » 02. January 2012 22:51

Thanks for the feedback.
FrankZ wrote:this seems to have done the trick!!
http://community.apachefriends.org/f/viewtopic.php?p=179699#p179740
That pesky Windows web server IIS which is wrongly enabled by default is a well known issue in these forums as is Skype for some.

I am pleased you found that post and were able to solve your problem

I will close this now and mark it solved.

Please feel free to start a new topic if you have any other XAMPP for Windows issues.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 27 guests