MySQL admin error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySQL admin error

Postby je543 » 28. December 2011 02:26

Hi,

I have just downloaded and installed the XAMPP control panel for windows. OS is windows xp sp3.
The services start but when I go to the MySql Admin the PhpmyAdmin window opens with the following error:

"Error
MySQL said:

#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)

Connection for controluser as defined in your configuration failed".


Any advise towards fixing this would be appreciated.


regs,

je543
je543
 
Posts: 9
Joined: 28. December 2011 02:12
Operating System: Windows XP sp3

Re: MySQL admin error

Postby Sharley » 28. December 2011 02:36

je543 wrote:I have just downloaded and installed the XAMPP control panel for windows
Do you mean you downloaded and installed the XAMPP Control Panel Version 3 and after clicking on the Start buttons Apache and MySQL are running?

Open in your text editor \xampp\mysql\bin\my.ini file and uncomment this line so it looks like this
Code: Select all
bind-address="127.0.0.1"
Save the file and then stop and re-start MySQL - try Admin again.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: MySQL admin error

Postby je543 » 01. January 2012 14:57

Hi,

I went to the My.ini file in the bin folder inside the Mysql folder in xampp, the file name just displays as "My", (with no .ini extension) It appears as a configuration settings file?. Maybe this is correct.

I opened the file and removed the hash quote infront of the line.

I re-started the Xampp control panel v.1.7.7, the services started but the same error appeared again.

I then went back to the file and removed the hash sign at the start of the block of commands. This did not fix it either.

Any further advise would be appreciated.



Je543
je543
 
Posts: 9
Joined: 28. December 2011 02:12
Operating System: Windows XP sp3

Re: MySQL admin error

Postby Sharley » 01. January 2012 23:54

To see the .ini file extension that is hidden by your Windows configuration try the following:
In your Windows control panel click on Folder Options then on the View tab.

Look for and select Show hidden files and folders
Remove the tick in the box next to Hide extensions for known file types.

Click Apply and then OK.

Close the Windows control panel.

You should now be able to see that the my is now my.ini.


Try this:
Open the \xampp\phpmyadmin\config.inc.php file in your text editor and change this
Code: Select all
$cfg['Servers'][$i]['auth_type'] = 'config';
to
Code: Select all
$cfg['Servers'][$i]['auth_type'] = 'cookie';
Save the file and restart Apache and MySQL (Stop and then Start).

The User is root with no password unless you have created one in the XAMPP orange Welcome (Admin) page http://localhost under the security menu item and detailed in the readme_en.txt file in the xampp folder.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: MySQL admin error

Postby je543 » 03. January 2012 09:26

Hi,

Thanks for info, file extensions can now be seen again. Without making any further changes, oddly the PhpMyAdmin window now opens, but it is really slow opening and can take minutes loading.

Could you advise how I stop .php filetypes opening in Dreamweaver without uninstalling Dreamweaver?


Regs,


je543
je543
 
Posts: 9
Joined: 28. December 2011 02:12
Operating System: Windows XP sp3

Re: MySQL admin error

Postby Sharley » 03. January 2012 10:47

je543 wrote:I then went back to the file and removed the hash sign at the start of the block of commands. This did not fix it either.
You should return this back to the default state as it may be affecting this
je543 wrote:but it is really slow opening and can take minutes loading.


je543 wrote:Could you advise how I stop .php filetypes opening in Dreamweaver without uninstalling Dreamweaver?
Yes you can right click on a php file and select to Open with... then click on Choose a program... and select from the list of programs your text/code editor, notepad++ or notepad for example and then tick the box to Always use the selected program to open this kind of file. then click OK and the php files should now be associated with your text/code editor.

Now when ever you double click on a php file it will open in your text editor for reading and editing instead of DW.

This will have no effect on the file being parsed by your web server when ever you have a php file in a URI, for example
http://localhost/index.php
the php code will be parsed by the web server normally.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: MySQL admin error

Postby Sharley » 03. January 2012 11:11

You may also like to try the version 3 control panel found in the xampp installation folder:
xampp-control-3-beta.exe
Close the older 2.5 version first before double clicking on this new version.

For the latest version the download link is in my signature.
Simply extract all the files from the archive to the xampp installation folder and overwrite when asked.
Then right click the exe to create a shortcut to the desktop, for example, for easier access.

This version 3 (XCPv3) control panel has many new features including a much more detailed log window to help with troubleshooting start issues.


BTW, you should be logged into your Windows XP as an administrator to get the full benefit from XAMPP and all it's components, that is, if you are not already. ;)

Best wishes. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: MySQL admin error

Postby je543 » 04. January 2012 21:11

Hi,

I am now using the Xampp Control Panel v3. With this version the MySQL server module appeared as running, but when I went to set passwords in the Xampp security Console, the message was it was either not running or blocked by a firewall. I found that removing the hash quote from the My.ini file in front of "bind-address 127.0.0.1" fixed this.

As the computer administrator, for extra security I have set my own password to log in when the computer initially starts up. For Xampp and MySQL directory I set passwords in the security console, but when I log into Apache Admin, in the "Run As" box that appears I have to untick "Protect my computer and data from unauthorized program activity" to log in. It will not allow me to log in unless this is unticked. I hope this is secure enough.

It will not accept any other username and password in the fields below.

Any further info would be appreciated.


thanks,

Je543
je543
 
Posts: 9
Joined: 28. December 2011 02:12
Operating System: Windows XP sp3

Re: MySQL admin error

Postby Sharley » 05. January 2012 00:23

je543 wrote:I am now using the Xampp Control Panel v3
Did you download the latest version and use it instead as I believe the issue with the Run As window may have been resolved.

The latest version download link is in my signature.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: MySQL admin error

Postby je543 » 05. January 2012 19:40

Hi,

Yes, I am using Xampp Control Panel v.3. I tried to uninstall the older v.2.5 using the uninstaller in case it may be interfering with the newer version, but as it unintalled the modules I downloaded xampp 1.1.7 again. I then started the Xampp Control Panel v.3, and after setting passwords again, I stopped and exit.

I then restarted the Xampp Control Panel, but when I start an Apache or MySQl service, the "Run as" box appears, I then have to untick "the message to prevent my computer and data from unauthorized activity". In "the Run as box" It says that unticking this may have less security? . When I press on "admin" I enter my password, but I am not sure if this is secure after unticking in the "Run as" box.
Its the same when I try to stop a service, - the option in the "Run as" box has to be unticked.

Any further advise would be appreciated.


Regs,

Je543
je543
 
Posts: 9
Joined: 28. December 2011 02:12
Operating System: Windows XP sp3

Re: MySQL admin error

Postby Sharley » 05. January 2012 23:17

Can you type here the name of the control panel exe file in the xampp folder that you are using please?

It should be similar to this but with a version number on the end:
xampp-control-3-beta[version number].exe
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: MySQL admin error

Postby Sharley » 06. January 2012 03:10

@seablue711
Your post has been moved here because your issue is not the same and your XAMPP version is different.
viewtopic.php?f=16&t=49501
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: MySQL admin error

Postby je543 » 09. January 2012 15:50

Hi,

Yes, the control panel exe file version in the Xampp folder is xampp-control-3-beta.exe When opened it is v.3.0.2.



regs,


je543
je543
 
Posts: 9
Joined: 28. December 2011 02:12
Operating System: Windows XP sp3

Re: MySQL admin error

Postby Sharley » 09. January 2012 20:57

I will post this again in case you missed it and is why I asked for the name of the version 3 file name, you are still running the first version of this control panel and it has been improved since then
Sharley wrote:For the latest version the download link is in my signature.
Simply extract all the files from the archive to the xampp installation folder and overwrite when asked.

Then right click the exe to create a shortcut to the desktop, for example, for easier access.

This version 3 (XCPv3) control panel has many new features including a much more detailed log window to help with troubleshooting start issues.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: MySQL admin error

Postby je543 » 11. January 2012 10:57

Hi,

Yes, as mentioned, this is the xcp.v3.0.2. which was downloaded via the link in your signature, it is different in appearance to the 2.5 version, I tried both the xcp.3 version and the xcp.3 beta version. I did not come accross any newer version than the version I already have following the link from your signature or from the Xampp download links page. http://www.apachefriends.org/en/xampp-windows.html#641??


After uninstalling everything and re-installing, I am now getting the same initial message when I try to log in to MySQL admin. I have also tried the steps to fix it.

Error
MySQL said:

#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)
Connection for controluser as defined in your configuration failed.


I had previously downloaded the zip binary version of xampp, but I could not get it to work, so I deleted it and installed the installer version. I am still using xcp.v.3.0.2.

Any further advice would be appreciated.


regs,

Je543
Last edited by je543 on 11. January 2012 19:58, edited 2 times in total.
je543
 
Posts: 9
Joined: 28. December 2011 02:12
Operating System: Windows XP sp3

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 64 guests