Port change doesn't have an effect (XP) 1.7.7 [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Port change doesn't have an effect (XP) 1.7.7 [SOLVED]

Postby jeffamm » 27. December 2011 02:36

I've installed XAMPP 1.7.7 (Control Panel 2.5) but Apache will not start and stay started. The people helping me to diagnose this have asked me to look at what the log file says, but my log folder in C:\xampp\apache\logs is empty. I searched the forums here and didn't find anything on this. Can anyone suggest a fix?
Last edited by jeffamm on 27. December 2011 18:02, edited 1 time in total.
jeffamm
 
Posts: 4
Joined: 27. December 2011 02:29
Operating System: windows xp

Re: Log file missing

Postby Sharley » 27. December 2011 04:42

You may need to download and install the VC9 runtime file from here:
http://www.microsoft.com/download/en/de ... px?id=5582

The clue is that no logs files have been created which would be the case if Apache had ever started.

BTW you may like to use the Control Panel Version 3 found in the xampp folder
xampp-control-3-beta.exe
and a link to the latest version can be found in my signature.

Best wishes. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Port change doesn't have an effect

Postby jeffamm » 27. December 2011 15:01

Sharley,

Thanks - I'd been looking around for how to install cp3 and then found your link. And also, it was very helpful to understand that no log file means apache never started. Makes sense but this is my first time with any of this software so I didn't get the link. With cp3 going I get the error messages below in the control panel display. So I have a couple of questions:

In troubleshooting this earlier I read about the port 80 issue, and thought I had IIS installed, so I tried changing the apache port to 8080 by going to the C:\xampp\apache\conf folder and editing the httpd.conf so that the LISTEN area is as follows:

Listen 0.0.0.0:8080

Is that the right way to set the port to 8080? It doesn't seem to be working. Any other ideas?

Also, I tried installing the VC9 code and the options I got were repair and uninstall which I take to mean that I already had it. I repaired it anyway but found no change in behavior.

8:47:05 AM [main] Xampp version: 1.7.7
8:47:05 AM [main] Control center version: 3.0.2 [ Compiled: Jul 21th 2011 - build #1 ]
8:47:05 AM [main] Running as admin - good!
8:47:05 AM [main] Working with basedir: "c:\xampp\"
8:47:05 AM [main] Initializing moduls
8:47:05 AM [apache] Possible problem detected: Port 80 in use by "inetinfo.exe"!
8:47:05 AM [apache] Possible problem detected: Port 443 in use by "inetinfo.exe"!
8:47:05 AM [mysql] "c:\xampp\mysql\bin\mysqld.exe" seems to be running on port 3306?
8:47:05 AM [mercury] Possible problem detected: Port 25 in use by "inetinfo.exe"!
8:47:05 AM [mercury] Possible problem detected: Port 25 in use by "inetinfo.exe"!
8:47:05 AM [main] Starting check-timer
jeffamm
 
Posts: 4
Joined: 27. December 2011 02:29
Operating System: windows xp

Re: Port change doesn't have an effect

Postby Altrea » 27. December 2011 22:27

Hi jeffamm,

jeffamm wrote:In troubleshooting this earlier I read about the port 80 issue, and thought I had IIS installed, so I tried changing the apache port to 8080 by going to the C:\xampp\apache\conf folder and editing the httpd.conf so that the LISTEN area is as follows:

Listen 0.0.0.0:8080

Is that the right way to set the port to 8080? It doesn't seem to be working. Any other ideas?

Yes, thats the correct setting.
Make sure you change the setting ServerName too. It's in the same file.

A few more hints:
- After changing the Apache configuration files, you have to restart the Apache server. Otherwise the changes doesn't take effect.
- 8080 is the default port for the Apache Tomcat server. If you want to use this too, you have to find a different solution.
- Port 443 (default port for HTTPS/SSL) must be changed too. You can find its Listen setting in file \xampp\apache\conf\extra\httpd-ssl.conf

jeffamm wrote:8:47:05 AM [apache] Possible problem detected: Port 80 in use by "inetinfo.exe"!
8:47:05 AM [apache] Possible problem detected: Port 443 in use by "inetinfo.exe"!

The monitoring for blocked ports must be changed too. In the new CPv3 you can simply configure the new ports to look at in it's configuration dialog.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Port change doesn't have an effect

Postby Sharley » 27. December 2011 22:37

The best solution is to return your httpd.conf file to it's default state so it listens on port 80.

Then disable IIS as it conflicts with many components in XAMPP as can be seen in your XCPv3 log window.

These instructions may help:

To disable IIS go to
Start>Control Panel>Add or Remove Programs
on the leftmost side you will find an option
Add or Remove Windows Components
click on it and then uncheck
Internet Information Services (IIS)
you can click on Details to make sure all IIS components are unchecked.
Click OK
and then restart your computer.

You should not have any conflicts with the XAMPP components now. ;)

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Port change doesn't have an effect

Postby jeffamm » 28. December 2011 00:48

Altrea, thanks for the tips, I'm going to try disabling IIS first, then if I get it working, I may come back to your suggestions if I find I need IIS to run

Sharley, thanks again for the reply, I disabled IIS which got rid of all errors but one related to msdepsvc.exe and port 80. (Apache still doesn't start). I looked up msdepsvc.exe and it is apparently associated with IIS, but my IIS is definitely unchecked (and I have rebooted). Any ideas?

6:42:36 PM [main] Initializing main
6:42:36 PM [main] Windows version: 5.1 (build 2600) - Service Pack 3
6:42:36 PM [main] Xampp version: 1.7.7
6:42:36 PM [main] Control center version: 3.0.2 [ Compiled: Jul 21th 2011 - build #1 ]
6:42:36 PM [main] Running as admin - good!
6:42:36 PM [main] Working with basedir: "c:\xampp\"
6:42:36 PM [main] Initializing moduls
6:42:36 PM [apache] Possible problem detected: Port 80 in use by "msdepsvc.exe"!
6:42:36 PM [main] Starting check-timer
6:42:48 PM [apache] Starting apache app...
6:42:49 PM [apache] Status change detected: running
6:42:50 PM [apache] Status change detected: stopped
jeffamm
 
Posts: 4
Joined: 27. December 2011 02:29
Operating System: windows xp

Re: Port change doesn't have an effect

Postby Sharley » 28. December 2011 01:09

This is the MS Web Deployment Agent Service (MsDepSvc.exe)

You first need to establish that this file MSDepSvc.exe is genuine as it is often a malware file - check it with an anti-virus utility or check it using an online scan service like http://www.virustotal.com/

If the file is clean then perhaps you can find out how to disable this service in this topic down near the end:
viewtopic.php?f=16&t=46841

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Port change doesn't have an effect

Postby jeffamm » 28. December 2011 02:37

I checked it with virustotal and it indicates that it is a good program

I have visual studio 2010 installed so not surprised to have IIS and related code running

I looked at your links and didn't find a clean way to disable msdepsvc.exe so I just did a ctrl-alt-del, brought up the task manager and ended the msdepsvc process. I was then able to start and run apache, so essentially the problem is fixed, albeit in a brute force way. That's good enough for now until/unless I run into some problem where I need apache and msdepsvc to both run at the same time.

thanks for your assistance, hope this thread helps some others

I don't see how to mark this as solved
jeffamm
 
Posts: 4
Joined: 27. December 2011 02:29
Operating System: windows xp

Re: Port change doesn't have an effect

Postby Sharley » 28. December 2011 02:44

Thanks for your feedback. 8)

I will mark this topic solved.

Best wishes. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests