(Help)Error when pressing the start button on the panel xamp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

(Help)Error when pressing the start button on the panel xamp

Postby RieqyNS13 » 26. December 2011 16:57

I already download xampp 1.7.7 and install it directly.
after all is installed in C: \ Program Files \ xampp,
I immediately open the XAMPP Panel.
But when I press the button "start" on MySql, why even error, inside the white box directly inscribed as: "ERROR: MySql service not started [-1]".
Likewise, when I press button "start" on Apache, which is happening and Error in the white box also says "ERROR: Apache service not started [-1]"

And I open the localhost (127.0.0.1), WebBrowser instead display the message "Not Found", which should go to the XAMPP Panel

ScreenShot

Are there any who can help me to solve this problem?
RieqyNS13
 
Posts: 2
Joined: 26. December 2011 16:42
Operating System: Windows

Re: (Help)Error when pressing the start button on the panel

Postby JonB » 26. December 2011 21:34

in C: \ Program Files \ xampp,


Well - since its a bad idea to place XAMPP in folders that contain spaces and/or special characters - I suggest you install it in a more routine location like say 'c:\xampp'

The most reliable way to install is to use the zip or 7z distribution downloads, extract the files, move to your selected location, and then run the 'setup_xampp.bat' file in the root of \xampp.

Good Luck
8)




yisf
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: (Help)Error when pressing the start button on the panel

Postby RieqyNS13 » 27. December 2011 06:18

day before yesterday, I had to install it in C: \ xampp, with a different version of xampp, but it happened just the same, still occur ERROR in Apache and MySql
RieqyNS13
 
Posts: 2
Joined: 26. December 2011 16:42
Operating System: Windows

Re: (Help)Error when pressing the start button on the panel

Postby JonB » 27. December 2011 20:02

Well, its important to know the version you currently have installed in c:\xampp, along with the exact Windows Version in use.

Which XAMPP Control Panel were you using? Did you have them (Apache and MySQL) 'ticked as services'???

The -1 errors 'generally' are indicative of an Operating System Error - i.e that The Windows Services were not properly installed.

read this topic -

http://www.codingforums.com/showthread.php?t=153803

And this XAMPP topic -
viewtopic.php?f=16&t=49273&p=190015&hilit=services+installed#p190015

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests